[mythtv-users] lirc fails to start on bootup but works when run manually

homebreweverything homebreweverything at myway.com
Thu Mar 25 11:41:12 EST 2004

 As I said, I tried adding a modprobe lirc_i2c before launching lircd, it didn't work. I also tried modprobe ivtv, that didn't work either.  I had mythbackend running before lircd, as I had mythbankend in run levels 2-5 and lircd in 5, and that also didn't work.  I searched the list before posting and tried the common solutions :)  Any other ideas? I didn't know much about linux distributions when I selected RedHat, my experience before installing Myth was mostly with FreeBSD and Solaris.  Homebreweverything is more of a goal than a title :)  But, it's not in reference to my OS, I built a car computer/mp3 player, I'm working on a diy projector and a kegerator, and hope to be actually doing some home brewing of the beer kind soon.  So many projects, so little time...  Not so sure my myth box even counts as home brewed, since all I did was compile code.   Thanks,Mike--- On Thu 03/25, Jarod Wilson < jcw at wilsonet.com > wrote:From: Jarod Wilson [mailto: jcw at wilsonet.com]To: mythtv-users at mythtv.org, homebreweverything at myway.comDate: Wed, 24 Mar 2004 21:45:36 -0800Subject: Re: [mythtv-users] lirc fails to start on bootup but works when run manuallyOn Mar 24, 2004, at 19:49, homebreweverything wrote:> I have setup a myth box and it's been working great, except on a > reboot, lircd does not startup correctly. I have a PVR350 with the > grey remote, Myth 0.14 compiled from CVS, lirc compiled from CVS on > 3/24/2004, and ivtv 0.1.9, compiled from sources. I'm running RedHat > 9.0 with a custom kernel.>> I have tried adding /sbin/modprobe lirc_i2c in the lircd init.d > script, as well as modprobe ivtv. I've tried compiling Myth with and > without native lirc support. I've tried moving the alais in > modules.conf for lirc_i2c to the begining, after the path > declarations, and after ivtv. I've also tried lirc-0.7pre2, which had > the same problem, and lirc-0.7pre3, which didn't work at all, but I > read on the lists that this distribution was broken.>> Does anyone have any i
deas?Yes. Your ivtv driver must be loaded up before lirc_i2c can find the IR receiver. I just load up mythbackend before lirc (S86 vs. S90), but you could also kludge a modprobe lirc_i2c into your lircd init script, which when modprobing lirc_i2c would also load up ivtv, because of the add above statement in modules.conf.And "homebreweverything"? Not if you're using Red Hat... Try LFS (or at least Gentoo) if that's really your mantra. ;-)-- Jarod C. Wilson, RHCEGot a question? Read this first...http://catb.org/~esr/faqs/smart-questions.htmlMythTV, Fedora Core & ATrpms documentation:http://wilsonet.com/mythtv/MythTV Searchable Mailing List Archivehttp://www.gossamer-threads.com/archive/MythTV_C2/Attachment: PGP.sig (0.19KB)

No banners. No pop-ups. No kidding.
Introducing My Way - http://www.myway.com
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mythtv.org/pipermail/mythtv-users/attachments/20040325/d21c645a/attachment.html

More information about the mythtv-users mailing list