[mythtv-users] lirc fails to start on bootup but works when run manually

homebreweverything homebreweverything at myway.com
Wed Mar 24 22:49:11 EST 2004

I have setup a myth box and it's been working great, except on a reboot, lircd does not startup correctly. I have a PVR350 with the grey remote, Myth 0.14 compiled from CVS, lirc compiled from CVS on 3/24/2004, and ivtv 0.1.9, compiled from sources. I'm running RedHat 9.0 with a custom kernel.I have tried adding /sbin/modprobe lirc_i2c in the lircd init.d script, as well as modprobe ivtv. I've tried compiling Myth with and without native lirc support. I've tried moving the alais in modules.conf for lirc_i2c to the begining, after the path declarations, and after ivtv. I've also tried lirc-0.7pre2, which had the same problem, and lirc-0.7pre3, which didn't work at all, but I read on the lists that this distribution was broken.Does anyone have any ideas? Since switching to native lirc support this has become more of an issue, since I not only need to manually launch lircd, but also restart myth. If I can't get it to work, I'll switch back to irxevent, but that causes the focus issue with mplayer I've heard. I've tried all the various mouse-on-focus mods.My config files are included below. My lircd.conf is copied from the ivtv tree. To manually start it I would login as root, and execute /sbin/service lircd start, then as my mythtv user run irxevent &, or with native lirc support in myth, restart mythfrontend.Thanks!-----------------modules.conf----------------------# For ivtvpath[toplevel]=/lib/modules/`uname -r`/drivers/media/video# For bttv and saa7134path[toplevel]=/lib/modules/`uname -r`/v4l2# default pathpath[toplevel]=/lib/modules/`uname -r`# ivtv modules setup#alias char-major-81-1 bttvalias char-major-61 lirc_i2calias char-major-81 videodevalias char-major-81-0 ivtvoptions ivtv debug=1options tuner type=2options msp3400 once=1 simple=1add below ivtv msp3400 saa7115 tuneradd above ivtv lirc_dev lirc_i2c# monitoring sesnors#alias char-major-89 i2c-devalias usb-controller usb-ohcialias usb-controller1 ehci-hcdalias usb-interface usb-ohcialias eth0 nvnet# ALSA portionalias char-major-116 sndalias snd-card-
0 snd-intel8x0#options snd-intel8x0 mpu_port=0x330# OSS/Free compatability portionalias char-major-14 soundcore# Sound card #1alias sound-service-0-0 snd-mixer-ossalias sound-service-0-1 snd-seq-ossalias sound-service-0-3 snd-pcm-ossalias sound-service-0-8 snd-seq-ossalias sound-service-0-12 snd-pcm-oss# Save & restore settingspost-install snd-card-0 /usr/sbin/alsactl restore >/dev/null 2>&1 || :pre-remove snd-card-0 /usr/sbin/alsactl store >/dev/null 2>&1 || :alias char-major-195 nvidia---------------------------lircd init.d script---------------------#!/bin/sh## $Id: lircd.init,v 1.1 2002/09/28 11:54:12 dude Exp $# Startup script for the Linux Infrared Remote Control.## chkconfig: - 90 10# description: Enables infrared controls through LIRC.## config: /etc/lircd.conf# Source 'em up. /etc/init.d/functions[ -x /usr/local/sbin/lircd ] || exit 1[ -x /usr/local/sbin/lircmd ] || exit 1[ -f /etc/lircd.conf ] || [ -f /etc/lircmd.conf ] || exit 1PATH=/usr/local/sbin:/usr/local/bin:$PATHRETVAL=0start(){if [ -f /etc/lircd.conf ]; thenecho -n $"Starting infrared remote control daemon: "/sbin/modprobe lirc_i2cdaemon lircdRETVAL=$?echofiif [ -f /etc/lircmd.conf ]; thenecho -n $"Starting infrared remote control mouse daemon: "daemon lircmdRETVAL=$?echofitouch /var/lock/subsys/lircdreturn $RETVAL}stop(){if [ -f /etc/lircmd.conf ]; thenecho -n $"Stopping infrared remote control mouse daemon: "killproc lircmdechofiif [ -f /etc/lircd.conf ]; thenecho -n $"Stopping infrared remote control daemon: "killproc lircdechofiRETVAL=$?rm -f /var/lock/subsys/lircdreturn $RETVAL}restart(){stopstart}# See how we were called.case "$1" instart)start;;stop)stop;;restart)restart;;status)status lircd;;condrestart)[ -e /var/lock/subsys/lircd ] && restart;;*)echo $"Usage: $0 {start|stop|status|restart|condrestart}"RETVAL=1esacexit $RETVAL

No banners. No pop-ups. No kidding.
Introducing My Way - http://www.myway.com
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mythtv.org/pipermail/mythtv-users/attachments/20040324/e2b55b58/attachment.htm

More information about the mythtv-users mailing list