[mythtv-users] Fedora Core/Jarod's Guide/ pcHDTV (HD-2000) card

Erick Burtness erickb at burtnesseng.com
Wed Mar 17 19:20:43 EST 2004

At 04:52 PM 3/15/2004, you wrote:
>Hello all,
>I have a question.  I have followed Jarod Wilson's guide for myth tv on 
>Fedora Core (thank you Jarod), and am now sitting here with the following 
>$uname -r
>I am attempting to compile the drivers for the pcHDTV (HD-2000) card , and 
>am coming up against the following errors.
>bttv-if.c:255: error: unknown field `inc_use' specified in initializer
>bttv-if.c:255: warning: initialization from incompatible pointer type
>bttv-if.c:256: error: unknown field `dec_use' specified in initializer
>bttv-if.c:256: warning: missing braces around initializer
>bttv-if.c:256: warning: (near initialization for 
>bttv-if.c:256: warning: initialization makes integer from pointer without 
>a cast
>bttv-if.c:256: error: initializer element is not computable at load time
>bttv-if.c:256: error: (near initialization for 
>bttv-if.c:257: error: initializer element is not constant
>bttv-if.c:257: error: (near initialization for `bttv_i2c_adap_template.name')
>make: *** [bttv-if.o] Error 1
>If anybody has successfully compilied the driver for the pcHDTV (HD-2000) 
>card under the ATRpms kernel I would love to know how.

Hey John,

I ran into this problem last week. It appears that this compile problem is 
due to interface changes in the i2c subsystem between the version that the 
current pcHDTV drivers were written for and version 2.8.4 which is used by 
the 2.4.22-1.2174.nptl_37.rhfc1.at kernel. See 
http://secure.netroedge.com/~lm78/ for more info.

I tried editing bttv-if.c so that it looked like the bttv-if.c included 
with the ATRpms kernel. My changes also matched the patches at the link 
above. At that point the drivers compiled fine, but when I installed them 
and tried to run dtvsignal or getatsc, the programs would segfault and 
hang. I don't know if the problem was with my changes or if there was some 
other problem with the combination of those drivers and that kernel.

I ended up just using Fedora'a 2.4.22-1.2174.nptl kernel. The drivers 
compiled and have been working fine.


More information about the mythtv-users mailing list