[mythtv-users] How to get Homebrew transmitter to work?

Steven Rubano srubano at ccap.net
Mon Mar 15 11:07:00 EST 2004

Hi all, 

This is the first time I am posting to this list. My setup is as follows:

-          ASUS Pundit Barebone system

-          P4 1.6 MhZ proc

-          512Meg of RAM

-          Hauppauge PVR350 Capture card

-          120Gig Maxtor, 7200rpm, 8meg cache drive

-          KnoppMyth R4V2 and I upgraded the Distro package via "apt-get


So far I have everything such as the Hauppauge Remote, TV out on the PVR
350, Sound (although I am still trying to get my Optical Digital sound
working on the ASUS for 5.1, if you have any ideas, let me know) and MythTv
fully functional. What I can't get to work is my home brew serial
transmitter (http://www.lirc.org/improved_transmitter.html) working. I know
it works since I loaded up LIRC for windows and connected it to my PC and
was able to send commands to it.


Here's what I did to get another instance of LIRC to run to try and control
my serial transmitter: http://members.cox.net/rwraithr/IRBlaster_Howto.txt

I followed this exactly (except for placing all the configuration files
appropriately for KnopMyth such as instead of using the /etc/modules.conf, I
placed it in the ivtv config file in knoppmyth, etc. I also used the
lirc2remote.sh script (found here:  http://members.cox.net/rwraithr/) to
convert LIRC.


After doing all this I then ran ./setup.sh and chose Option 1, Homebrew
Serial on for my COMM 1 port (the correct IRQ's and such match what's in my
BIOS settings), select Transmit diode and Software carrier then ran the
config. After following the IRBLAster_Howto.txt on making the file then make
install and copied my Digital Cable box remote config file to remoted.conf
to the /etc/ directory, I tried loading up remote_serial manually (which was
renamed from lirc_serial) and everything loads fine.so far so good. The
problem I run into is when I do a "remote_irsend SEND_ONCE SA2000 POWER" I
receive something to the effect of  "Your device does not support sending".
I already performed the "setserial ttyS0 uart none" command prior to
everything. Here's where I'm stuck! I've tried everything, even running
./config.sh -with-transmitter...anyone have any Ideas?? 


Also when I place this into my ivtv config:


path[toplevel]=/lib/modules/`uname -r`/misc
alias char-major-72 remote_sir
below remote_sir remote_dev
options remote_sir irq=4 io=0x3f8
and this in my start Daemon:
echo "Starting remoted..."
setserial /dev/ttyS0 uart none
/sbin/modprobe remote_sir
my Hauppauge grey remote stops working after reboot. Do these have to be
loaded last? After my original Lirc for the Hauppauge remote? Before it? Any
insight on this would be greatly appreciative. 
Getting my TV out to work on my Hauppauge PVR350 was a piece of cake, but
this one has got me licked. I have a fully functional box minus the fact the
ability to change channels!
Thanks in advance,
P.S. I tried to keep this short so if anyone needs to see my full config
files email me and I'll email it to you, I don't want to clog the list with


This message contains confidential information and is intended only for the 
individual(s) named. If you are not the named addressee you should not 
disseminate, distribute or copy this e-mail. Please notify the sender 
immediately by e-mail if you have received this e-mail by mistake and delete 
this e-mail from your system. The sender does not accept liability for any 
errors or omissions in the content of this message.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mythtv.org/pipermail/mythtv-users/attachments/20040315/acfff28c/attachment.html

More information about the mythtv-users mailing list