[mythtv-users] LIRC: Beware of brain-dead packagers! (was: Lirc problems w/PVR-2

John Minor theminor at hotmail.com
Mon Mar 15 10:59:19 EST 2004

Alright - I think that might be the problem - now how do I solve it?  Jarod 
was right about the pre1 issue.  After "rpm -qa |grep lirc", I get only the 
rpms that I installed, all the newest.

As far as the ivtv issue, I don't know what is going on.  Aaron, how did you 
get the ivtv kernel drivers to load properly before lirc?  I followed 
Jarod's guide if editing my modules.conf - here it is entirely:

path[toplevel]=/lib/modules/`uname -r`/updates
# default path
path[toplevel]=/lib/modules/`uname -r`

alias char-major-61 lirc_i2c

alias eth0 tulip
alias char-major-81 bttv
alias usb-controller usb-uhci
alias ieee1394-controller ohci1394

# ivtv modules setup
alias char-major-81 videodev
alias char-major-81-0 ivtv
options ivtv ivtv_debug=1 mpg_buffers=90
options tuner type=2 # NTSC tuner
options msp3400 once=1 simple=1
add below ivtv msp3400 saa7115 tuner
add above ivtv lirc_dev lirc_i2c

# alias char-major-61 lirc_i2c
# alias char-major-81 bttv

# alias sound-slot-0 audigy
# post-install sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -L 
 >/dev/null 2>&1 || :
# pre-remove sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -S >/dev/null 
2>&1 || :

alias char-major-195 nvidia

# --- BEGIN: Generated by ALSACONF, do not edit. ---
# --- ALSACONF verion 1.0.3 ---
alias char-major-116 snd
alias char-major-14 soundcore
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss
alias snd-card-0 snd-emu10k1
alias sound-slot-0 snd-emu10k1
# --- END: Generated by ALSACONF, do not edit. ---

I tried swapping the location of the "alias char-major-61 lirc_i2c" and 
"alias char-major-81 bttv" lines to down below the lirc stuff (where the 
same lines are commented out above the video driver line), but starting irw 
still causes lirc to stop.  I also tried moving the location of that line 
just above the "add above ivtv lirc_dev lirc_i2c" line, but still no luck.  
So, Aaron, how did you get the ivtv kernel drivers to load properly before 
lirc?  Again, thanks for the help!



I found that this problem occurs if ivtv is not loaded.  lirc worked for
me when I followed Jarod's instructions, but then, after rebooting, it no
longer worked.  lircd quit as soon as I launched irw.  I spent hours
trying to figure this out.  The solution is to make sure that ivtv is also
loaded.  The ivtv kernel module must be loaded first--it is needed to find
the IR device.

Another way to confirm that the device is not found is by cat'ing=20
/dev/lirc.  If it says something like "no such device", then that's=20
exactly what the problem is.


On Sun, 14 Mar 2004, Jarod C. Wilson wrote:

>On Mar 14, 2004, at 21:46, John wrote:
> > Well, it looks like this issue isn=92t completely resolved =96 I am sti=
> > having problems getting LIRC to stay alive with my PVR-250=85 I=92ve be=
> > working on this problem for quite some time now, and I decided to=20
> > start over completely.=A0 I reformatted and followed Jarod=92s guide.=
=A0 I=20
> > installed the lirc-0.7.0-25_cvs20040311 kernel module and build.=A0 It=
> > worked great until I rebooted.
>Hm... Its working for me... But I haven't been rebooting much at all...
> > Before rebooting irw gave me feedback and everything when I pressed=20
> > buttons on my remote.=A0 After rebooting, though, irw stops and the lir=
> > daemon stops as well.=A0 I tried running lirc =96n to watch the output =
> > it says:
> >
> > Lircd 0.7.0pre1[2518]: lircd(any)ready
> > Lircd 0.7.0pre1[2518]: Accepted new client on /dev/lircd
> > Lircd 0.7.0pre1[2518]: Could not open /dev/lirc
> > Lircd 0.7.0pre1[2518]: Default_init(): No such device
> > Lircd 0.7.0pre1[2518]: Caught signal
> > Terminated
> >
> > That was really troubling
>Indeed... No clue why that's happening though... :-\
> > but here is the really strange part: Look at the version number.=A0 To=
> > make sure I wasn=92t losing my mind, I tried lirc =96v and it indeed=20
> > returned 0.7.0pre1
> >
> > How did the version revert to pre1?
>It really is pre3. That was covered a while back on the list. Something=
>to do with the way the lirc code is in CVS, or something... Verify what=
>you've got with "rpm -qa |grep lirc" and you shouldn't see any pre1=20
>stuff, and you can verify by compiling current lirc cvs source=20
> > Unfortunately, I didn=92t check the version before rebooting, but I=20
> > assume that it was pre3, since that is what I installed =96 right?=A0 I=
> > don=92t think it would have worked before the reboot without the versio=
> > being pre2 or the latest CVS version of pre3 that I installed (or at=20
> > least that is what I intended to install).
> >
> > Any ideas?=A0 I=92ve been working on this problem for days now =96 and =
> > can=92t seem to resolve it.=A0 This is the closest I have some, seeing =
> > how it actually worked there for a minute!=A0 Before I cleanly installe=
> > the latest CVS version I would always get the same error.=A0 Maybe lirc=
> > just hates me.=A0 Anyway, I=92d *really* appreciate some help!=A0 Thank=
s so=20
> > much in advance,
>I'm most of the way through another clean install myself on a dev box=20
>(w/my PVR-350). I'll see if I can dig anything up...
>Jarod C. Wilson, RHCE
>Got a question? Read this first...
>      http://catb.org/~esr/faqs/smart-questions.html
>MythTV, Fedora Core & ATrpms documentation:
>      http://wilsonet.com/mythtv/
>MythTV Searchable Mailing List Archive
>      http://www.gossamer-threads.com/archive/MythTV_C2/

Get a FREE online computer virus scan from McAfee when you click here. 

More information about the mythtv-users mailing list