[mythtv-users] mtd DVDPerfectThread read failed and wrong audio channel being ripped

Eric Hammersley eric at sassi.com
Mon Mar 15 10:11:09 EST 2004

Right off I'll say that I don't know about your job failing, but I can
help with the audio track.

I've had a few DVD's do this lately, most recently Radio.  The DVD in
perfect rip is basically a copy off the disk, it pulls all the audio
tracks.  From what I read mplayer will grab the audio track it deems
correct from the stream.  In the case of Radio it would grab the
Director Commentary.  A custom mplayer command for those specific DVD
rips will do the trick.  Match your basic mplayer launch string from
setup but add something like -aid 128 to it.  This will play back the
correct audio file.  128 may not do it for you.  Launch the vob file in
the GUI mplayer and right click on the playback, there's a menu option
for audio where you can choose the track.  Check the different tracks
until you find the audio you want, then add that number to your -aid
line.  That's how I handle it...

-----Original Message-----
From: mythtv-users-bounces at mythtv.org
[mailto:mythtv-users-bounces at mythtv.org] On Behalf Of mikef at zerompg.com
Sent: Monday, March 15, 2004 4:03 AM
To: mythtv-users at mythtv.org
Subject: [mythtv-users] mtd DVDPerfectThread read failed and wrong audio
channel being ripped

  I recently setup MythTV, everything seems to work great, but mtd is
giving me problems. I have been able to successfully rip a dvd with
other programs (with the right audio channel). But mtd seems to always
choose the audio track I dont want. I also get the "DVDPerfectThread
read failed" error right when the rip is about to end. I've tried 2 dvds
so far and have gotten the same error at the end (different block counts
though). Playback works great with both mplayer and xine, the correct
audio channel is used too. The only way I can tell its using the wrong
audio channel is by starting a rip and going to the Video plugin to play
the video being ripped. The only other weird thing I noticed was the
file its writing to doesnt have a vob extension , its usually something
like "blah_001of".
I'm thinking of just commenting out lines 465-473 in jobthread.cpp of
mtd source. Does anyone have any other sugguestions? The DVD's dont seem
to be scratched that bad. Do programs like DVDrip ignore missing blocks
and just rip anyway? Heres the mtd output below if it helps:
Thanks ahead of time for any help.

00:51:50: Waiting for connections/jobs
00:51:50: mtd is listening on port 2342
libdvdread: Using libdvdcss version 1.2.7 for DVD access
00:51:53: DVD inserted: blah
00:51:53:             : Title 1 is of type 4 (dvdinput table)
00:52:33: a client socket has been opened
00:52:46: launching job: job dvd 1 1 0 0 -1 /var/lib/mythvideo/blah
libdvdread: Using libdvdcss version 1.2.7 for DVD access
00:52:51: job thread beginning to rip dvd title

libdvdread: Attempting to retrieve all CSS keys
libdvdread: This can take a _long_ time, please be patient

libdvdread: Get key for /VIDEO_TS/VIDEO_TS.VOB at 0x0000012e
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_01_0.VOB at 0x0000016c
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_01_1.VOB at 0x00013feb
libdvdread: Elapsed time 0
libdvdread: Found 1 VTS's
libdvdread: Elapsed time 0
01:07:02: Error: DVDPerfectThread read failed for 59 blocks at 2078086
01:07:04: job failed: job dvd 1 1 0 0 -1 /var/lib/mythvideo/blah

mythtv-users mailing list
mythtv-users at mythtv.org

More information about the mythtv-users mailing list