[mythtv-users] LIRC: Beware of brain-dead packagers! (was: Lirc problems w/PVR-250)

Jarod C. Wilson jcw at wilsonet.com
Mon Mar 15 02:46:34 EST 2004

On Mar 14, 2004, at 21:46, John wrote:

> Well, it looks like this issue isn’t completely resolved – I am still 
> having problems getting LIRC to stay alive with my PVR-250… I’ve been 
> working on this problem for quite some time now, and I decided to 
> start over completely.  I reformatted and followed Jarod’s guide.  I 
> installed the lirc-0.7.0-25_cvs20040311 kernel module and build.  It 
> worked great until I rebooted.

Hm... Its working for me... But I haven't been rebooting much at all...

> Before rebooting irw gave me feedback and everything when I pressed 
> buttons on my remote.  After rebooting, though, irw stops and the lirc 
> daemon stops as well.  I tried running lirc –n to watch the output and 
> it says:
> Lircd 0.7.0pre1[2518]: lircd(any)ready
> Lircd 0.7.0pre1[2518]: Accepted new client on /dev/lircd
> Lircd 0.7.0pre1[2518]: Could not open /dev/lirc
> Lircd 0.7.0pre1[2518]: Default_init(): No such device
> Lircd 0.7.0pre1[2518]: Caught signal
> Terminated
> That was really troubling

Indeed... No clue why that's happening though... :-\

> but here is the really strange part: Look at the version number.  To 
> make sure I wasn’t losing my mind, I tried lirc –v and it indeed 
> returned 0.7.0pre1
> How did the version revert to pre1?

It really is pre3. That was covered a while back on the list. Something 
to do with the way the lirc code is in CVS, or something... Verify what 
you've got with "rpm -qa |grep lirc" and you shouldn't see any pre1 
stuff, and you can verify by compiling current lirc cvs source 

> Unfortunately, I didn’t check the version before rebooting, but I 
> assume that it was pre3, since that is what I installed – right?  I 
> don’t think it would have worked before the reboot without the version 
> being pre2 or the latest CVS version of pre3 that I installed (or at 
> least that is what I intended to install).
> Any ideas?  I’ve been working on this problem for days now – and I 
> can’t seem to resolve it.  This is the closest I have some, seeing as 
> how it actually worked there for a minute!  Before I cleanly installed 
> the latest CVS version I would always get the same error.  Maybe lirc 
> just hates me.  Anyway, I’d *really* appreciate some help!  Thanks so 
> much in advance,

I'm most of the way through another clean install myself on a dev box 
(w/my PVR-350). I'll see if I can dig anything up...

Jarod C. Wilson, RHCE

Got a question? Read this first...
MythTV, Fedora Core & ATrpms documentation:
MythTV Searchable Mailing List Archive
-------------- next part --------------
A non-text attachment was scrubbed...
Name: PGP.sig
Type: application/pgp-signature
Size: 186 bytes
Desc: This is a digitally signed message part
Url : http://mythtv.org/pipermail/mythtv-users/attachments/20040314/ebdb9c07/PGP.pgp

More information about the mythtv-users mailing list