[mythtv-users] Echostar & IR Blaster

Ajay ssharma at revsharecorp.com
Tue Mar 9 01:33:42 EST 2004

Frank Linhares wrote:

> Try using lirc.0.7.pre2

I upgraded to lirc 0.7.pre2 and I'm having the same problem... 
Everything looks okay but it's just not registering on my Echostar box.  
Can you explain step 2 in your directions 

"Ensure that your Echostar Set Top Box and remote is set to System ID 9"

The model # of my Dish Network unit is 2700, it's pretty old.  I did 
manage to dig out the manual but there was nothing in there about 
changing the System ID.  Can you tell me how it's done on your unit?  Is 
this something I should try to call support about?  If I can't get this 
thing to work soon I'm probably going to switch to DirectTV just so I 
can use the serial port.  Well, that and Echostar is going to lose CBS 
in a few hours:



> On 5-Mar-04, at 1:05 PM, Ajay Sharma wrote:
>> Frank Linhares wrote:
>>> If anyone out there is using Myth & lirc with an echostar box, I 
>>> have written up a how to on getting it to work properly.  The how to 
>>> can be found on www.pvrcentral.net under the faq section.
>> I was stoked to read this (abit brief) howto on getting an IR blaster 
>> working with my echostar box (dish network 2700, super old).  So I 
>> ordered an ir transmitter (ACT-IR200L) and started playing around 
>> with it tonight.  I'm running into a few problems so hopefully 
>> someone can help me out.
>> I'm running gentoo linux with vanilla-sources 2.4.25, I installed 
>> lirc 0.6.6 manually just so I got the ./configure line correct:
>> ./configure --with-module-dir=/lib/modules/2.4.25/misc/  \
>>    --with-syslog --with-driver=act200l --with-major=61 \
>>    --with-port=0x3f8 --with-irq=4 --with-transmitter --prefix=/opt/lirc
>> Then a make and make install which threw everything into /opt/lirc.
>> I built the echostar_raw and used it to create my /etc/lirc.conf 
>> file. I did a 'modprobe lirc_sir', should I be modprobing anything else?
>> (output from dmesg):
>> lirc_sir: I/O port 0x03f8, IRQ 4.
>> enable_irq(4) unbalanced from e3c43b52
>> lirc_sir: Installed.
>> then I ran '/opt/lirc/sbin/lirc -n':
>> lircd 0.6.6[22206]: lircd(act200l) ready
>> I modified the "change-channel-lirc.pl" script in the mythtv contrib 
>> folder to use the /opt/lirc/bin/rc program, adjusted the remote name 
>> to "JVC_RAW", and changed the final "ENTER" command to "SELECT" to 
>> match up with the key in /etc/lirc.conf.  Now when I run the script 
>> ('./change-=channel-lirc.pl 244') I don't get any output.  In the 
>> "lirc -n" window I get:
>> lircd 0.6.6[22206]: accepted new client on /dev/lircd
>> lircd 0.6.6[22206]: removed client
>> lircd 0.6.6[22206]: accepted new client on /dev/lircd
>> lircd 0.6.6[22206]: removed client
>> lircd 0.6.6[22206]: accepted new client on /dev/lircd
>> lircd 0.6.6[22206]: removed client
>> So it looks like it's sending the commands but nothing is happening.
>> I've even tried switching the serial ports as maybe I have com1 and 2
>> mixed up but that wasn't it.
>> In the instructions I don't know how to change my system id to '9' and
>> I lost the manual for my receiver a long time ago.
>> Is lirc 0.6.6 cool or should I be using a pre-release of 0.7?  I do 
>> have a pvr250 and plan on using that for my ir receiver.  Part 1 of 
>> this is just to get my computer to control my dish network box.
>> I'd appreciate any help as the lirc stuff is the last piece to my 
>> mythtv puzzle.
>> Thanks,
>> Ajay

More information about the mythtv-users mailing list