[mythtv-users] [OT] Can't transcode DVDs w/MythDVD on FC1 (ATrpms kernel)

Joseph A. Caputo jcaputo1 at comcast.net
Mon Mar 8 13:55:50 EST 2004

First, let me preface this by saying that I know this is *not* a MythDVD 
problem, but I know there are a bunch of folks out there with FC1 
installations using ATrpms kernels (following Jarod's guide), and I'm 
hoping someone has solved this.  First, my config:

Athlon XP 1600+
Asus A7A266
Fedora Core 1
ATrpms kernel-2.4.22-1.2174.nptl_37.rhfc1.at

The problem is the transcode package... it hangs.  I can do a 'perfect' 
rip (with MythDVD or dvd::rip), but any kind of transcoding operation 
causes transcode (or one of its child processes:  tccat, tcextract, 
etc...) to hang.  MythDVD says "Transcode is thinking...", dvd::rip 
just says "Initializing...".

According to some posts in the transcode ML, the culprit is not (as I'd 
have thought) NPTL, but RedHat's "exec-shield" patch.  I've tried their 
solution "echo 0 > /proc/sys/kernel/exec-shield", and it didn't help.  
The big difference is that that solution was posted for a stock Fedora/
RH9 kernel, and I don't know if the ATrpms kernel is the problem.

So, is anyone out there with a "Jarod's guide" installation successfully 
ripping & transcoding DVDs?

My last-resort solution will be to try and patch a vanilla kernel.  Has 
anyone done this?  I'll need at least XFS support & whatever is 
required for ivtv (v4l2?).


More information about the mythtv-users mailing list