[mythtv-users] Problems with "Recording Priorities" screen?

Bruce Markey bjm at lvcm.com
Thu Mar 4 16:32:15 EST 2004

Joseph A. Caputo wrote:
> Is anyone else having a problem with the recording priorities screen?
> When I go in there now, I get a list filled with chanids instead of 
> program titles.  When I highlight an item, in the info at the bottom I 
> get time strings like "2003-05-12T19:00:00" (today's date, zero time) 
> instead of a channel number.  All of the 'garbage' entries indicate 
> 'Not recording this showing', except for one which has a blank title 
> and channel 'Any'.
> At the bottom of the list are 5 seemingly randomly-selected recordings 
> that show up correctly.  I've examined my database & everything looks 
> kosher, plus Myth is correctly recording even the shows that are 
> showing up as garbage in the 'recording priorities' screen.

Well, you're obviously running mis-matched...

> Yes, my frontend & backend match; both running cvs from last night 
> (3/03).


> In my terminal (for mythfrontend) I see:
> 2004-03-04 14:02:46 Using protocol version 4
> QTime::fromString: Parameter out of range
> (repeated may times)
> QTime::setHMS Invalid time 24:00:00.000
> Anybody else have problems with this?

I'm running current and don't see this problem. One might think
(I'm not sayin' me) that this could happen if data was lost on
the network but not if this happens every time. Every once in
a while I see an empty or nearly empty list but then reload and
it's fine.

One thing I've seen happen is if a bogus entry is in the 'record'
table it can show a weird entry but not as you describe. Still,
you may want to look at your record table for things like a NULL
title or non-printable chars in text fields. Also, run mysqlcheck
for good measure.

--  bjm

More information about the mythtv-users mailing list