[mythtv-users] Problem with Debian unstable packages (probably SQL)

Nick Traxler ntraxler at usfamily.net
Sat Jul 31 19:05:08 EDT 2004

I have a single-machine Debian unstable system that I'm trying to set up 
as a Myth box. I'm using the deb packages listed at:

And my system:
2xPentium 3/1000Mhz
512 MB
Nvidia GeForce4 MX 440
Hauppage WinTV 401 (I think that's the model # - it has the FM tuner and 
stereo outputs, no MPEG encoder)

The packages seem to install fine, add a user, and add a DB in mysql. I 
run mythtv-setup as the mythtv user, get most of the stuff configured, 
and I can see my lineup from DataDirect. But, when I go into the channel 
editor, it sits for at least five minutes without populating the list 
with any channels. I hit escape and exit from the program, and this is 
in the terminal window:

---terminal output---
DB Error (Inserting into dd_genre):
Query was:
INSERT INTO dd_genre (programid, class, relevance) 
Driver error was [2/1146]:
QMYSQL3: Unable to execute query
Database error was:
Table 'mythconverg.dd_genre' doesn't exist

<repeated many times, beyond xterm's buffer>

If this is the master backend server:
Now, please run '/etc/cron.daily/mythtv-backend' as root to populate the 
with channel information.

--- end terminal output---

So, I checked in mysql, and there is indeed no dd_genre table in the 
mythconverg database:
| Tables_in_mythconverg      |
| callsignnetworkmap         |
| capturecard                |
| cardinput                  |
| channel                    |
| codecparams                |
| conflictresolutionany      |
| conflictresolutionoverride |
| conflictresolutionsingle   |
| credits                    |
| dvb_channel                |
| dvb_pids                   |
| dvb_sat                    |
| dvb_signal_quality         |
| favorites                  |
| housekeeping               |
| jumppoints                 |
| keybindings                |
| keyword                    |
| mythlog                    |
| networkiconmap             |
| oldprogram                 |
| oldrecorded                |
| people                     |
| profilegroups              |
| program                    |
| programgenres              |
| programrating              |
| recgrouppassword           |
| record                     |
| recorded                   |
| recordedmarkup             |
| recordingprofiles          |
| recordoverride             |
| settings                   |
| transcoding                |
| videosource                |

So, has anyone else had problems like this with the Debian packages? I 
only saw one sql file, '/usr/share/mythtv/sql/mc.sql', and it was two 
lines long. (A create database statement and a grant for the mythconverg 

I don't know how the tables get created with the deb packages, but it 
looks like they're being created by an out-of-date script. I've tried 
purging the packages, dropping the database and mythtv user in mysql, 
and doing userdel on the mythtv user, then deleting their home 
directory. When I reinstall from scratch, the problem still happens. 
I've tried searching this list and Googling for lots of stuff, but I 
never see any hits. Any ideas?

Thanks in advance for any help.

------ http://USFamily.Net/info - Unlimited Internet - From $8.99/mo! ------

More information about the mythtv-users mailing list