[mythtv-users] DVB-T playback thru PVR, odd ff/rw problem

Stephen Longhurst steve at longsteve.com
Fri Jul 30 05:04:59 EDT 2004

>> Problem:
>> However, any ff/rw when playing back Nova-T recordings causes an a/v
>> pause followed by some HDD thrashing (whilst it seeks in the file I
>> assume) then play returns at the desired point. So ff/rw does work, just
>> not near-instantly like with the PVR recordings.
> I can fast ff/rw DVB recordings fine without any pauses, but only when
> a recording has completed.  If I attempt to jump forward or backwards
> in a program that is still recording, it jumps back to the very
> beginning!
>> Furthermore, the on-screen time display describes Nova-T recordings as
>> (e.g.) "00:05:06 of 1862:44:12" - something clearly not right there!
> I get the same thing on my machine too. It also looks like the time
> goes twice as fast when playing back. Only the time indication on
> the OSD though, not the actual playback, that's fine.
>> This leads me to suspect the PVR's ivtv-fb driver, but how can it affect
>> mythtv's seeking and estimation of recording length?! That doesn't make
>> sense to me. This is why I'm stumped!
> On my machine, I can switch pretty easily between PVR-350 TV output
> and it's Nvidia MX440 TV output (both are output to my TV at the same
> time through different TV inputs).  I'll give the Nvidia a try and see
> if that makes any difference.

I tried this this morning, playing back a DBT-T recorded program using
the Nvidia TV-Out (XV I presume) and it worked great. The length was
correct on the info display, I could edit the cutlist without any
problems, define a bookmark and jump to it without any problems. It's
also not specific to any OSD, since I tried several and they all
showed the same problem when using the PVR-350 output.

I don't think it's the ivtv-fb driver as that just displays the OSD,
but it is likely to be the ivtv decoder output support in mythtv
(unless that's what you meant?).  This could of course be related to
the ivtv driver itself though.  It might be returning an incorrect
frame count for the DVB-T mpeg file or something like that.

I would like to look into this more closely and get some time to look
at the code, but that's unlikely at the moment.  Still, somebody may
have an answer.



Stephen Longhurst
steve at longsteve.com

More information about the mythtv-users mailing list