[mythtv-users] Re: State of IvyTV Fedora Core 2 Support?

huffman at graze.net huffman at graze.net
Thu Jul 29 10:26:40 EDT 2004

Hmmmm...it definitely works.  I was able to get it working on Fedora Core 2 w/
the stock Fedora kernel.  I'll say that so far it isn't as stable as FC1 though.
 If you're interested, here are the steps I took:

1) Fresh FC2 install
2) Up2date to latest packages (including kernel)
3) loosely follow jarod's guide except:  get the ivtv-experimental rpms from the
atrpms site.  My modprobe.conf file is included.  It's a little strange, but I
just used the modules.conf from FC1 and used the generate-modprobe.conf command
in FC2 to generate the 2.6 style modprobe.conf:

alias eth0 e100
alias snd-card-0 snd-ice1712
alias usb-controller uhci-hcd
alias char-major-195* nvidia
alias char-major-61-* lirc_i2c
alias char-major-81-* videodev
alias char-major-81-0 ivtv
options ivtv ivtv_debug=1 tuner=2
options msp3400 once=0 simpler=1 simple=0
install ivtv { /sbin/modprobe msp3400; /sbin/modprobe saa7115; /sbin/modprobe
tuner; } ; /sbin/modprobe --first-time --ignore-install ivtv && { /sbin/modprobe
lirc_dev; /sbin/modprobe lirc_i2c; /bin/true; }
install net-pf-10 /bin/true
install snd-ice1712 /sbin/modprobe --ignore-install snd-ice1712 &&
/usr/sbin/alsactl restore >/dev/null 2>&1 || :
remove ivtv { /sbin/modprobe -r lirc_dev; /sbin/modprobe -r lirc_i2c; } ;
/sbin/modprobe -r --first-time --ignore-remove ivtv && { /sbin/modprobe -r
msp3400; /sbin/modprobe -r saa7115; /sbin/modprobe -r tuner; /bin/true; }
remove snd-ice1712 { /usr/sbin/alsactl store >/dev/null 2>&1 || : ; };
/sbin/modprobe -r --ignore-remove snd-ice1712

Kind of wierd....but it works.  


Discussion about mythtv <mythtv-users at mythtv.org> wrote: 
> having received my pvr 250 yesterday and spent all evening trying to get 
> ivtv working, i'm giving up and going to fedora core 1 :(
> after getting the 2.6.7 vanilla kernel, i tried to the cvs and stable 
> releases of ivtv with no joy (started off with loads of errors, sorted some 
> things out, but eventually hit a brick wall which i didn't know how to get 
> past). then i tried the atrpms packages (which automatically switched my 
> kernel too), and got reasonably far, but the ivtv module WOULD NOT load 
> ('dmesg | grep ivtv' showed an error saying that tveeprom could not be 
> loaded or something), so no /dev/video0.
> i spent some time in #mythtv-users getting help from Beirdo (thanks very 
> much btw, very kind of you), but after a string of problems (and not being 
> able to find a way to fix them), i downloaded the fc1 isos. at least this 
> means i can just follow jarod's guide to the letter, i'll leave fc2 to those 
> with a bit more experience for now :)
> cheers,
> joe.
> _________________________________________________________________
> Stay in touch with absent friends - get MSN Messenger 
> http://www.msn.co.uk/messenger

More information about the mythtv-users mailing list