[mythtv-users] My installation of the new NVidia Drivers requiring a Modprob every boot

Vincent K. Britton Vincent.Britton at wiznet.com
Wed Jul 7 00:13:19 EDT 2004

I know this isn't a myth problem but it is causing me problems with mythtv. :-)

I have installed the new drivers and everything works except for the fact that in order for my to startx I have to run "modprobe nvidia-1_0-6106" as root on every boot.  Otherwise I get and error "Fatal server error: no screens found"

Additional information:  I had to upgrade my kernel version (2.4.22-1.2197) to install these drivers as there were no atrpms available for my kernel.  I did upgrade the associated packages and ran "modprobe ivtv*" for the new kernel-module.  That all works fine but just not the video drivers.  I have uninstalled all the old drivers in an attempt to force the machine to see the videocard with the 6106 driver, to no avail.

Thanks for any assistance you can provide!


I thought this would be fixed by editing the modules.conf file but I don't know for sure.  It is pasted here in case it is relevant:
[root at localhost root]# more /etc/modules.conf
path[toplevel]=/lib/modules/`uname -r`/updates
# default path
path[toplevel]=/lib/modules/`uname -r`
alias char-major-61 lirc_i2c
alias usb-controller usb-ohci
alias usb-controller1 ehci-hcd
#alias usb-interface usb-ohci
# alias sound-slot-0 i810_audio
# post-install sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -L >/dev/null 2>&1 || :
# pre-remove sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -S >/dev/null 2>&1 || :
# alias sound-slot-1 nvaudio
alias usb-interface usb-ohci
# --- BEGIN: Generated by ALSACONF, do not edit. ---
# --- ALSACONF verion 1.0.4 ---
alias char-major-116 snd
alias char-major-14 soundcore
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss
alias snd-card-0 snd-intel8x0
alias sound-slot-0 snd-intel8x0

# --- END: Generated by ALSACONF, do not edit. ---
# ivtv modules setup
alias char-major-81 videodev
alias char-major-81-0 ivtv
options ivtv ivtv_debug=1 mpg_buffers=90
options tuner type=2 # NTSC tuner
options msp3400 once=1 simple=1
add below ivtv msp3400 saa7115 tuner
add above ivtv lirc_dev lirc_i2c

alias eth0 forcedeth
# nvidia kernel module
alias char-major-195 nvidia-1.0-6106

More information about the mythtv-users mailing list