[mythtv-users] New nVidia driver

Johnny Lee johnny at fishcounts.com
Fri Jul 2 16:37:38 EDT 2004

Usually that only works when you have two versions of the driver loaded.
Remove the old driver. Go manually delete them or apt-get if you used that
to apt-get remove nvidia-graphics-blah-blah. They are somewhere like
/usr/X11R6/lib/ and so forth. 

Johnny Lee

-----Original Message-----
From: mythtv-users-bounces at mythtv.org
[mailto:mythtv-users-bounces at mythtv.org] On Behalf Of m0j0.j0j0
Sent: Friday, July 02, 2004 10:15 AM
To: Discussion about mythtv
Subject: Re: [mythtv-users] New nVidia driver

On Fri, 2004-07-02 at 11:46, Jason Ramey wrote:
> I had to comment out:
> Load "glx"
> in XF86Config-4 to make it work when I got that error. Hope that
> helps.

hmmm... Commenting that out seems to allow X to load. Not sure how well
things work, since I'm not in front of the box at the moment. Kinda odd
since the nVidia README says that line is necessary. I did observe the
following error in the log now:

(II) Loading extension NV-GLX
(II) NVIDIA(0): NVIDIA 3D Acceleration Architecture Initialized
(II) NVIDIA(0): Using the NVIDIA 2D acceleration architecture
(==) NVIDIA(0): Backing store disabled
(==) NVIDIA(0): Silken mouse enabled
(**) Option "dpms"
(**) NVIDIA(0): DPMS enabled
(II) Loading extension NV-CONTROL
(EE) NVIDIA(0): Failed to load GLX

Also, 'xdpyinfo' shows only the "GLX" extension loaded and not "NV-GLX"
and "NVIDIA-GLX", which the README references. Will all OpenGL apps be
broken on this box now?

Any thoughts?


More information about the mythtv-users mailing list