[mythtv-users] Re: mythvideo compiling woes...

K.R. Foley kr at cybsft.com
Thu Jan 29 10:48:57 EST 2004

martin north wrote:
> I have a CVS build of mythtv which is about 2 weeks old, and it is 
> successfully working.
> K.R. Foley writes:
>> martin north wrote:
>>> hi,
>>> i am failing to compile mythvideo. I have installed all the kde 
>>> development stuff and all dependencies that i can find, but still 
>>> cant compile from CVS.
>>> The compile bombs out here:
>>> g++ -c -pipe -Wall -W -O3 -march=c3 -fomit-frame-pointer -D_REENTRANT 
>>> -fPIC  -D_GNU_SOURCE -DPREFIX=\"/usr/local\" -DQT_
>>> -I/usr/qt/3/mkspecs/linux-g++ -I. -I../../../include 
>>> -I/usr/qt/3//include -o vi
>>> deobrowser.o videobrowser.cpp
>>> videobrowser.cpp: In member function `void 
>>> VideoBrowser::selected(Metadata*)':
>>> videobrowser.cpp:674: error: `HandleMedia' undeclared (first use this 
>>> function)
>>> videobrowser.cpp:674: error: (Each undeclared identifier is reported 
>>> only once
>>>  for each function it appears in.)
>>> can anyone shed any light????
>> It looks to me like you haven't compiled and installed mythtv (from 
>> CVS) which I think will resolve this.
>> kr
>> -- 
>> K.R. Foley
>> kr at cybsft.com
>> www.cybsft.com

The reason that I came to this conclusion is that HandleMedia which is 
coming up undefined is in fact defined here:

mythdialogs.h:    bool HandleMedia(QString &handler, const QString &mrl);

Which is part of mythtv/libmyth which should be installed in 
/usr/local/include/mythtv. One of two possibilities that I see off the 
top of my head: 1) either mythtv hasn't actually been installed or is 
installed somewhere other than /usr/local/ (the prefix you are using for 
mythvideo) or 2) HandleMedia was added since your checkout (update) of 
mythtv. Don't know which, but maybe this will help you find the problem.


K.R. Foley
kr at cybsft.com

More information about the mythtv-users mailing list