[mythtv-users] Kanam / Accent remote

Carlos Fernandez Sanz cfs-myth at nisupu.com
Tue Jan 20 16:33:42 EST 2004


I'm trying to setup lirc to work with a Kanam (www.kanam.co.kr) remote. In
theory this brand is supported.

The hardware is working fine (tested with IRAssistant and the generic COM

I'm using standard kernel 2.4.23, locally compiled (with the serial port
support as a module).
I compiled lirc with the (homebrew 16x50 UART compatible serial port) serial
driver, using the default COM1 settings (which are correct). The driver
loads correctly, but I get this:

Jan 20 18:36:07 mythtv kernel: lirc_serial: in calc_pulse_lengths_in_clocks,
freq=38000, duty_cycle=50, clk/jiffy=25952256, pulse=34147, space=34148,
Jan 20 18:36:08 mythtv kernel: lirc_serial: auto-detected active high

(no idea if this "active high" thing is correct or not).

I compiled lirc with the debug option but I don't get a lot of extra
stuff... that's all I see.
Anyway, if I start irw, I get this in the lircd.log

Jan 20 18:54:02 mythtv lircd 0.6.6: accepted new client on /dev/lircd

Plus this in messages
Jan 20 18:54:02 mythtv kernel: lirc_serial: Interrupt 4, port 03f8 obtained

Both things seem ok to me.
However, I don't get any output from irw (tried mode2, too) no matter how
many buttons I press or how long I keep them pressed.

Of course I copied the correct conf file (from the database) in /etc, and
tried --force in irw.

Any idea? I'm stuck here.


-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mythtv.org/pipermail/mythtv-users/attachments/20040120/578ebe4e/attachment.html

More information about the mythtv-users mailing list