[mythtv-users] Experiences with fresh install on FC1...

Peter Valdemar Mørch swp5jhu02 at sneakemail.com
Sun Jan 4 19:16:55 EST 2004

Hi Jarod,

Thanks so much for your guide!

I just thought I'd funnel some experiences back! I currently have no
outstanding issues, but I did run into these snags when installing with
a Hauppauge 350 on a fresh fedora core (after getting it to work on RH9,
it was a mess and I started all over to get it clean)

1) ALSA - Is not an optional step, I found. Also if fedora detects your
sound card, you need to edit modules.conf to remove the sound card
lines. **And then you need to reboot**. Otherwise `service alsasound
start` fails and alsa doesn't get installed properly. And that alsa
installs a new kernel version, that must be ignored, because there is no
alsa-kmdl package for it.

2) Problem with focus in mythtvsetup for non-na tv_grab_XX

1) ALSA - Is not an optional step, I found. Or what?
I did run into some problems with Alsa.

I first missed the fact that alsa was an optional step. After trying
(and failing) to get alsa to work, I removed all the alsa rpms. I'm
pretty sure I got it back to where I started. The sound card worked.

But apparently it is not (any longer?) an optional step. (`apt-cache
depends libmyth` shows that alsa-lib is a dependency ) So `apt-get
install mythtv-suite` installs alsa whether you like it or not.

It was my experience, that my soundcard that worked fine before this
step but did not work after, so I had to get alsa working. Because my
soundcard got detected during fedora installation it was in
modules.conf, and in use at the time I installed the alsa rpms and tried
to run alsaconf. Edit modules.conf (as in Jarod's guide) and *reboot!*
to "release" the sound card. Then alsaconf worked for me.

Also, when alsa gets installled, a
"kernel-2.4.22-1.2129.nptl.caps.rhfc1.ccrma" package gets installed.
but there is no alsa-kmdl- for that kernel. So I'm still running with
the 'kernel-2.4.22-1.2135.nptl_27.rhfc1.at' without problems, even
though alsa seems to pull in the '.ccrma' one. (whatever that is).
Anyway, that new kernel can safely be ignored. (I don't know how to use
apt to query for what depends on exactly that kernel version. `apt-cache
whatdepends kernel#2.4.22-1.2129.nptl.caps.rhfc1.ccrma` just returns all
the packages that depend on the kernel - not very useful)

myth at peter:~/work/mythtv/libs/libmyth> sudo apt-get -s install
Reading Package Lists... Done
Building Dependency Tree... Done
E: Couldn't find package alsa-kmdl-2.4.22-1.2129.nptl.caps.rhfc1.ccrma

3) Problem with focus in mythtvsetup for non-na tv_grab_XX

I realize I reordered a couple of steps here, but I set up "focus
follows mouse"  before "mythtvsetup". But if you aren't in North America
where tv_grab_* requires input form the terminal (at least
tv_grab_(dk|uk|nz|es) do), and then you are required to interact with
the xterm|console from which you launched  mythfrontend. I'm sure you
see the focus problem... You can't alt-tab to the thingy. There seems to
be nothing else to do except (ALT-F2 + login + ps -ef | grep tv_grab +
kill -9 XXX).

Changing the focus policy or running mythsetup from one of the ALT-F#
terminals so you can switch back and forth seems to do be a workaround



More information about the mythtv-users mailing list