[mythtv-users] Slow-down between v0.13 and 0.14?

cmisip cmisip at insightbb.com
Sun Feb 29 11:08:54 EST 2004

I notice a slowdown also.  I tried recording three shows last night
simultaneously and saw frame dropping on all of them so I disabled the
one slave backend.  I am going to have to do with two and see if that
makes a difference as far as frame drops.  Also with two simultaneous
recording going on, playback of one of the currently recording movies is

I wonder if mythbackend is reserving cpu cycles unnecessarily.  I seem
to recall reading something about that somewhere.  Maybe there's a way
to adjust the priority of mythfrontend?

On Sun, 2004-02-29 at 00:12, jdpotter at excite.com wrote:
> My first post here; apologies if answered elsewhere:
> I upgraded from MythTV 0.13 to 0.14 and I'm noticing a reduction in playback capacity.  On v0.13, I was able to record and view at 480x480 in MPEG2-PS on my (minimally compliant) system: Pentium III-500, Hauppauge PVR250, 224MB RAM, SE440BX motherboard, GeForce4 MX400 with TV-out.  CPU usage was maybe 10% when only recording, 90% when viewing live TV, maybe 80% when playing a recording.  My bitrates, as I remember, where 2400 min, 4800 max for video, 224kbps for Audio (48kHz sampling).
> Now with v0.14 on the same machine, I can still view live TV at 480x480 or less, and can start recording and continue to view, with the CPU at 90% or less.  If I try to view a recording with the same settings as above, after it has finished, the CPU pegs at 100%, and I drop frames badly (regularly maybe once a second or two, with audio dropouts).  This choppiness even occurs when I start a recording while watching live TV, quit watching live (while recording continues), and go back to Watch Recording.  If I start up KSysGuard, I notice two threads of mythfrontend running, each with 30-45% of the CPU load while the choppiness occurs (but nowhere near this bad while watching live TV).
> The only settings I've gotten to work without choppiness are recording at 400x480, 1600 min - 4000 max, which gives lower quality than before.
> So, is there a problem with 0.14?  I compiled both 0.13 and 0.14 from source (I'm running Mandrake 9.2 with all its standard libs); did I leave some settings poorly set?  How do I attempt to fix?  Or are there settings within MythTV I may have screwed up?  Most everything remained at the old settings after I installed 0.14 and tried it the first time.
> I have also upgraded IVTV from 0.1.7 to 0.1.9, and xmltv to 0.5.29.  Anything else I should hit?
> Thanks in advance.
> _______________________________________________
> Join Excite! - http://www.excite.com
> The most personalized portal on the Web!
> ______________________________________________________________________
> _______________________________________________
> mythtv-users mailing list
> mythtv-users at mythtv.org
> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users

More information about the mythtv-users mailing list