[mythtv-users] Crashes, then fsck..

Mark Hodges mhodges at webbschool.com
Tue Feb 24 13:09:06 EST 2004

manu wrote:

> Le 24.02.2004 02:57:59, Mark Hodges a écrit :
>> I have a problem with MythTV Crashing. After a random time period of  
>> recording or watching live TV (paused or unpaused) mythtv hard-locks  
>> up. Ctrl-Alt-Del does nothing, I can't switch out to a console or  
>> kill X. After I do reboot I have to run a full fsck and rebuild the  
>> file system tree. I am using reiserfs and I have to run reiserfsfsck  
>> --rebuild-tree. I always lose the recent data after this, that  
>> includes logs and whatever was being recorded.  I have tried 
>> changing  settings, and change the hard drive that is being used for 
>> recording  (I have three).  My motherboard is an dfi nf2ultra 
>> (nforce2)  motherboard.  I have two hard drives running on the 
>> primary channel  on the second ide controller (an hpt370 ide 
>> controller). The master (hde) drive is where myth is installed, and 
>> the secondary drive(hdf)  is where I planned to store the videos.  
>> After the first lockup I  tried saving the videos to the primary 
>> drive(hde), and still got a  lock-up. The only other drive that I 
>> have is hda, and I can't save to  it because it is formatted ntfs.  I 
>> am running gentoo with a 2.6.3  kernel, and an ATI  tvwonder VE 
>> capture card.  My vid card is an  nvidia card, running the newest 
>> nvidia drivers. Any help would be  greatly appreciated, and tomorrow 
>> after the fsck finishes I will try  running the cvs version to see if 
>> that helps. But if there is any  sort of a ide issue or something 
>> simple that I am overlooking, help  would be greatly appreciated
> For NForce2 mobos you have to disable local apic (you have to pass  
> nolapic or/and noapic as kernel boot parameter). At least this was  
> necessary with 2.4.x kernels, I don't know if you still have to do 
> that  with 2.6.x.
> Bye
> Ma
> nu
Yeah, I forgot to include that I have tried passing the noacpi option to 
the kernel, in fact that is how I run things all of the time due to some 
other issues, I also use hdparm to enable dma, and have the idebus set 
at 66mhz. I have tried fiddling with all the hd settings that I know of 
and nothing gets any better.

More information about the mythtv-users mailing list