[mythtv-users] Re: Lirc and Mythtv (Hauppauge Gray Remote)

Aleaxander alex at carbonated.com
Sat Feb 14 00:45:51 EST 2004

mythgnomer at rowelab.com wrote:

> /var/log/lircd doesn't get created reliably unless you're using the init
> script.. (ie, If you're launching lircd manually, or from /etc/rc.local.)

I'm too much of a newbie to understand how I'm launching lirc, however...

> Irw just not running usually means that lircd isn't running (ps -aux | grep
> lirc before running irw) or check /dev/lirc (should not be a link to
> /dev/ttySx). If lircd is running, check for /dev/lircd.

I've confirmed lirc is running (results of ps -aux | grep lirc):
root 7217 0.0 0.1 4532 584 pts/2    S   22:31   0:00 grep lirc

and there is is nothing under /dev/lirc.  There is however a lircd 
socket in /dev/.

> Now, I've had some of the same problems after doing something like apt-get
> install mplayer - because that would also install liblirc 0.6.6.. So if none
> of the above works, uninstall lirc, updatedb, locate lirc and see what cruft
> is left behind.. If you have something like liblirc_client.so left over,
> whack it and install again. 

I did a search for liblirc* and the only results were:

I uninstalled lirc using synaptic, then I moved them out of /usr/lib/ 
(didn't seem like a good idea to delete them).

Then I restarted, but I ran into this problem:
mythfrontend: error while loading shared libraries: liblirc_client.so.0: 
cannot open shared object file: No such file or directory

I originally installed lirc using apt-get, so I tried:
# apt get install lirc-kmdl-$MYKERNEL

and received this error:
Couldn't find package lirc-kmdl-2.4.22-1.2163.nptl_32.rhfc1.at

Trying to reinstall lirc via synaptic tells me that I have broken 
packages (probably because they are a bit old at this point).  I think 
I'm heading for a complete reinstall of Fedora Core 1 and a reinstall 
per Jarod's guide, but then the this machine (the frontend) will be 
running a different version of MythTV than the backend, and I seem to 
recall that this can lead to problems, so I went with your next suggestion:

> I'd suggest installing from source, with the 0.7.0pre2 CVS snapshot
> (http://lirc.sourceforge.net/software/snapshots/lirc-0.7.0pre2.tar.bz2 -
> it's pretty easy to install this one from source.)

Downloaded this snapshot, extracted it, but haven't figured out how to 
install yet (and in my newbie way, I managed to extract everything to 
/home/mythtv/... quite a mess : ).  I'm getting pretty sleepy at this 
point (going on day 7 of 12 hour days at work... alas, the life of a 
video game developer), so I'll probably have to continue working on this 
tomorrow or the next day.  Thanks again for your suggestions.  If I 
figure out how to fix this, I'll of course let the list know in case 
anyone else (read total newbie) runs into the same problem.



More information about the mythtv-users mailing list