[mythtv-users] Re: Suid root, but mythtv complains that it isn't.

Tom Hughes tom at compton.nu
Fri Dec 31 13:01:36 UTC 2004

In message <20041224122635.GB8056 at neu.nirvana>
          Axel Thimm <Axel.Thimm at ATrpms.net> wrote:

> On Thu, Dec 23, 2004 at 10:04:41PM +0000, Tom Hughes wrote:
> > In message <20041223213955.GB25286 at main.templetons.com>
> >           Brad Templeton <brad+myth at templetons.com> wrote:
> > 
> > > I have mythfrontend owned by root and set to run suid.   However,
> > > when i run it it reports:
> > > 
> > > pthread-setschedparam: Operation not permitted
> > > Running as SUID root would allow some threads to run with realtime...
> > 
> > Same here. I have to actually run it as root to make that message
> > go away. I assume it must be giving up privileges too early.
> what about selinux? Did you try turning it off (selinux=0 in the
> kernel command line)? If that helps then having mythtv running suid
> will requires writing policies for it. :/

That does appear to fix it, yes. There were none of the usual selinux
warnings in the system log though or I would have tried that.


Tom Hughes (tom at compton.nu)

More information about the mythtv-users mailing list