[mythtv-users] WinTV Go 2 sound issues...

NYSSEN Peter (BMB) Peter.NYSSEN at proximus.net
Thu Dec 30 08:15:50 UTC 2004

I've found on http://www.bttv-gallery.de that this card is actually a
WinTV Go 2.

	-----Original Message-----
	From: mythtv-users-bounces at mythtv.org
[mailto:mythtv-users-bounces at mythtv.org] On Behalf Of NYSSEN Peter (BMB)
	Sent: Wednesday, December 29, 2004 10:02 AM
	To: mythtv-users at mythtv.org
	Subject: [mythtv-users] WinTV Go sound issues...

	Hi all, 

	I'm setting up MythTV 0.16 on a friend's box. It has a recent
WinTV Go card with a Conexant chip so I'm using the cx8800 kernel

	After fiddling a bit with the hue and color settings I got video
playback and recording just fine. I wish I could say the same about

	This card has a audio line-out. For use in MythTV this line-out
is connected to the line-in of the onboard sound card. 
	I'm also using tvtime to test the drivers. When using tvtime I
connect the line-out of the WinTV Go card directly to the amplifier of
my sound system.

	I've tried both the cx8800 v4l driver with kernel 2.6.9 and the
snapshot from

	Here are my experiences: 

	- tvtime (non-buffered playback) works perfect with both the
2.6.9 drivers and latest snapshot V4L drivers. Line-out of the WinTV Go
card is connected directly to my sound system.

	- mythtv with kernel 2.6.9 V4L drivers: I can't get any sound
out of this. I can change channels, playback and record video, but
without audio.

	- mythtv with V4L snapshot drivers:The same as with kernel 2.6.9
drivers, except that with these drivers a radio device is now also
detected while loading the drivers. When I'm doing TV playback on mythtv
(without sound), and I do a 'cat /dev/v4l/radio0', the tuned frequency
of the card changes, mythtv playback switches to static, and i _do_ get
static out of the speakers all of a sudden. Note that in this case the
line-out of the WinTV Go card is connected to the line-in of the sound
card. When I now change the channel in mythtv, I get normal tv playback
_with_ audio. Video and audio are perfectly in sync. I can change
channels and audio keeps on working. If I now press the 'r' key on the
keyboard to record the live stream audio get's turned off again. I'm
watching the tv stream without sound. Also if I exit live playback and
play back the recording stream from the media library, I see that no
sound is being recorded. If I do 'cat /dev/v4l/radio0' again, I can
watch live (buffered) TV again with sound.

	There is no radio device detected with the kernel 2.6.9 cx8800
V4L driver so I can't try this with those drivers 
	As you can see in the dmesg output below, with the snapshot
drivers a radio device is created and not with the kernel 2.6.9 drivers.

	Also, the snapshot drivers detect a MSP3425 audio processor but
the msp3400.ko module is not needed for audio to work. 

	Since unbuffered TV playback in tvtime is working fine and via
'cat /dev/v4l/radio0' I can get sound output on the WinTV Go card
enabled in MythTV, I suppose the problem lies in MythTV itself.

	Has anybody seen this before? Is this card maybe not yet
supported in MythTV? Or maybe the CVS version of MythTV has some fixes
for this?

	Thanks & kind regards, 

	root # lsmod 
	Module                  Size  Used by 
	snd_pcm_oss            48296  0 
	snd_mixer_oss          17536  1 snd_pcm_oss 
	lirc_dev               10636  0 
	tuner                  19624  0 
	cx8800                 25616  0 
	v4l1_compat            12804  1 cx8800 
	v4l2_common             4480  1 cx8800 
	cx88xx                 45792  1 cx8800 
	i2c_algo_bit            8328  1 cx88xx 
	video_buf              16708  2 cx8800,cx88xx 
	ir_common               3844  1 cx88xx 
	btcx_risc               3592  2 cx8800,cx88xx 
	tveeprom                7364  1 cx88xx 
	i2c_core               19024  4
	videodev                7232  2 cx8800,cx88xx 
	usbhid                 22720  0 
	uhci_hcd               28752  0 
	usbcore               101732  4 usbhid,uhci_hcd 
	nvidia               4813076  0 
	snd_via82xx            22692  0 
	snd_ac97_codec         68624  1 snd_via82xx 
	snd_pcm                84680  2 snd_pcm_oss,snd_via82xx 
	snd_timer              21188  1 snd_pcm 
	snd_page_alloc          7432  2 snd_via82xx,snd_pcm 
	gameport                3520  1 snd_via82xx 
	snd_mpu401_uart         6080  1 snd_via82xx 
	snd_rawmidi            19684  1 snd_mpu401_uart 
	snd                    45796  8

	soundcore               7328  1 snd 

	dmesg when kernel 2.6.9 V4L drivers are loaded: 

	cx88xx: Unknown parameter `audio_debug' 
	Linux video capture interface: v1.00 
	cx2388x v4l2 driver version 0.0.4 loaded 
	cx8800[0]: found at 0000:00:06.0, rev: 3, irq: 10, latency: 32,
mmio: 0xde000000 
	cx8800[0]: subsystem: 0070:3401, board: Hauppauge WinTV 34xxx
models [card=1,autodetected] 
	cx8800[0]: i2c register ok 
	cx8800[0]: hauppauge eeprom: model=34704, tuner=LG TPI8PSB11D
(29), radio=no 
	tuner: Ignoring new-style parameters in presence of obsolete
	tuner: chip found at addr 0xc2 i2c-bus cx8800[0] 
	tuner: type set to 29 (LG PAL_BG (TPI8PSB11D)) by cx8800[0] 
	cx8800[0]: i2c attach [client=LG PAL_BG (TPI8PSB11D)] 
	cx8800[0]: registered device video0 [v4l2] 
	cx8800[0]: registered device vbi0 
	cx8800[0]: set_audio_standard_BTSC (status: known-good) 
	cx8800[0]: cx88: tvaudio thread started 
	lirc_dev: IR Remote Control driver registered, at major 61 

	dmesg when latest snapshot V4L drivers are loaded: 

	Linux video capture interface: v1.00 
	cx2388x v4l2 driver version 0.0.4 loaded 
	cx2388x: snapshot date 2004-12-17 
	cx88[0]: subsystem: 0070:3401, board: Hauppauge WinTV 34xxx
models [card=1,autodetected] 
	tveeprom: Hauppauge: model = 34704, rev = E148, serial# =
	tveeprom: tuner = LG TP18PSB11D (idx = 48, type = 29) 
	tveeprom: tuner fmt = PAL(B/G) (eeprom = 0x04, v4l2 =
	tveeprom: audio_processor = MSP3425 (type = 15) 
	cx88[0]: registered IR remote control 
	cx88[0]/0: found at 0000:00:06.0, rev: 3, irq: 10, latency: 32,
mmio: 0xde000000 
	tuner: chip found at addr 0xc2 i2c-bus cx88[0] 
	tuner: type set to 29 (LG PAL_BG (TPI8PSB11D)) by cx88[0] 
	cx88[0]/0: registered device video0 [v4l2] 
	cx88[0]/0: registered device vbi0 
	cx88[0]/0: registered device radio0 
	lirc_dev: IR Remote Control driver registered, at major 61 


**** DISCLAIMER ****

"This e-mail and any attachment thereto may contain information which is confidential and/or protected by intellectual property rights and are intended for the sole use of the recipient(s) named above. This email is not intended to create or affect any contractual arrangements between the parties.
Any use of the information contained herein (including, but not limited to, total or partial reproduction, communication or distribution in any form) by other persons than the designated recipient(s) is prohibited. 
If you have received this e-mail in error, please notify the sender either by telephone or by e-mail and delete the material from any computer".

Thank you for your cooperation.

For further information about Proximus mobile phone services please see our website at http://www.proximus.be or refer to any Proximus agent.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mythtv.org/pipermail/mythtv-users/attachments/20041230/fe3143c8/attachment.html

More information about the mythtv-users mailing list