[mythtv-users] Re: [ATrpms-users] [FC3 / PVR-350 Out Broken?]

Michael Cheshire (Mailing Lists) michael-mlists at cheshire.id.au
Sun Dec 26 05:55:47 UTC 2004


Further to that - it appears that the same problem occurs under FC2.

I was able to get the ivtv and ivtv module to load under using these old rpms :


Any later kernels and the ivtv_fb crashes on loading.

I beleive I did have it working with atrpms kernel version 2.6.8-1.521 - but you can't get this kernel is no longer on the atrpms site.

I've tried adding video=vc:0-0 to the kernel boot options - doesnt fix the issue.

There must be something I'm missing? Does anyone have the later kernel verisons of FC2 or FC3 running with PVR-350 TV-OUT? 

What did you do to get it working? (or does someone has the old 2.6.8-1.521 i686 atrpm kernel somewhere for download?? :) )

  ----- Original Message ----- 
  From: Michael Cheshire (Mailing Lists) 
  To: atrpms-users at atrpms.net 
  Sent: Sunday, December 26, 2004 10:55 AM
  Subject: [ATrpms-users] [FC3 / PVR-350 Out Broken?]

  Ladies and Gentlemen :)

  Has anyone got the PVR-350 TV-OUT working properly on FC3?

  I've seen lots of posts regarding problems with this. I'm using atrpms to install everything and I've tried everything up to at-testing.

  I was actually using FC2 with everything working great, and upgraded the kernel (from an ATRPMS kernel to the latest FC2 one), which broke the TV-OUT stuff so I figured I would upgrade to FC3, but havent been able to rectify the problem. 

  The capture side of things works fine - it just seems to segfault when you modprobe the ivtv_fb module.

  dmesg dump :

  saa7115: decoder set picture bright=127 contrast=63 saturation=63 hue=0
  saa7115: decoder set picture bright=127 contrast=63 saturation=63 hue=0
  saa7115: decoder set picture bright=127 contrast=63 saturation=63 hue=0
  saa7115: decoder set picture bright=127 contrast=63 saturation=63 hue=0
  ivtv-osd: Framebuffer module loaded (attached to ivtv card id 0)
  ivtv-osd: Framebuffer is at decoder-relative address 0x00510000 and has 1704960 bytes.
  ivtv-osd: screen coords: [0 0] -> [720 576]
  ivtv-osd: original global alpha = 208
  ivtv-osd: current OSD state = 39
  ivtv-osd: new global alpha = 208 (1 255 0)
  ivtv-osd: framebuffer at 0xf1510000, mapped to 0x33990000, size 1620k
  ivtv-osd: mode is 720x576x32, linelength=2880
  Unable to handle kernel NULL pointer dereference<1>Unable to handle kernel NULL pointer dereference at virtual address 00000000
   printing eip:
  *pde = 00000000
  Oops: 0000 [#1]
  Modules linked in: ivtv_fb(U) i915 microcode xfs msp3400(U) saa7127(U) saa7115(U) tuner(U) tveeprom(U) ivtv(U) i2c_algo_bit i2c_core videodev button battery ac md5 ipv6 joydev ohci1394 ieee1394 uhci_hcd ehci_hcd snd_intel8x0 snd_ac97_codec snd_pcm_oss snd_mixer_oss snd_pcm snd_timer snd_page_alloc gameport snd_mpu401_uart snd_rawmidi snd_seq_device snd soundcore tg3 ext3 jbd dm_mod ata_piix libata sd_mod scsi_mod

  <blah blah>

  Otherwise it looks like I have to reinstall FC2 :(



  atrpms-users mailing list
  atrpms-users at atrpms.net
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mythtv.org/pipermail/mythtv-users/attachments/20041226/0b73c757/attachment.htm

More information about the mythtv-users mailing list