[mythtv-users] lirc and FC3

Krunoslav Pisacic k.pisacic at vip.hr
Tue Dec 21 11:05:51 UTC 2004

I don't believe that Jarod suggestion from http://bugzilla.atrpms.net/show_bug.cgi?id=317 is 100% right (it gave me a good
push-start - thnx Jarod). Following  /dev/lirc simlink can not be created because previous line creates /dev/lirc as a folder.
Easiest way to fix is to use only this line in /etc/udev/rules.d/lirc.rules:

KERNEL="lirc0*", NAME="lirc"

or if you have multiple remotes add:

KERNEL="lirc[1-9]*",	NAME="lirc%n"



From: Andy Long [mailto:aslong at uark.edu] 
Sent: Tuesday, December 21, 2004 5:48 AM
To: mythtv-users at mythtv.org
Subject: [mythtv-users] lirc and FC3

It seems that almost everyone who has used FC3 with kernel 2.6.9 (or some deviant thereof) have had problems getting LIRC to work.
I have tried to get mine working, unsuccessfully.  I am following Jarod's guide, and have a PVR-250 using the IR receiver that comes
with it. I have done the fix found here:  http://bugzilla.atrpms.net/show_bug.cgi?id=317  but I have not been able to get it to
work.  It worked after first installing it, but died after the reboot (just like many other people have had problems with).  I have
played with some of the suggestions posted on the listserv as far as reinstalling LIRC, doing a "/sbin/depmod -a" and then
"/sbin/modprobe lirc_i2c", and then "/sbin/service lircd restart" (I've done those 3 things in various orders) but that doesn't get
it to work either.  Basically, when I run "/usr/bin/irw" it does nothing.  If I do it again, 
Can someone please post a workaround as far as how they got it working?  I'm still a n00b at this, so if you could be a bit
descriptive to help with my lack of knowledge with linux, that'd be great.
Kernel 2.6.9 (the one jarod's guide says to install here: http://wilsonet.com/mythtv/fcmyth.php#kernel)
PVR-250 w/ grey remote and the packaged IR receiver

More information about the mythtv-users mailing list