[mythtv-users] Off topic: Last resort for me. Can not get my dvb-c card to output video/audio on FC3, kernel 2.6.9-681

Richie Jarvis richie at helkit.com
Sun Dec 19 23:02:27 UTC 2004

Mark Anderson wrote:
> On Mon, 20 Dec 2004 08:07 am, Örjan wrote:
>>Hi !
>>I want to build a digital multimedia system for my home based on mythtv
>>with a client/server architecture.  Since i get my tv by cable (digital)
>>i have to use a (at least one) dvb card.
>>Been having some serious trouble in getting my dvb-card to work under
>>Fedora Core 3. Here is my setup:
>>Fedora Core 3, Kernel: 2.6.9-681_FC3
>>Hauppauge DVB-c premium card,CI and CAM (Hauppauge/Conax)
>>Using dvb drivers in kernel. udev/sysfs doesn't make devices so i use
>>the MAKEDEV-DVB.sh script from Linuxtv.
>>(btw. card works fine under windows)
>>lsmod gives:
>>Module                  Size  Used by
>>ves1820                11213  1
>>dvb_ttpci              74741  3
>>dvb_core               80873  5 ves1820,dvb_ttpci
>>saa7146_vv             47425  1 dvb_ttpci
>>video_buf              24261  1 saa7146_vv
>>saa7146                21613  2 dvb_ttpci,saa7146_vv
>>v4l1_compat            15941  1 saa7146_vv
>>v4l2_common             9921  1 saa7146_vv
>>videodev               13377  1 saa7146_vv
>>ttpci_eeprom            6465  1 dvb_ttpci
>>lspci gives:
>>02:03.0 Multimedia controller: Philips Semiconductors SAA7146 (rev 01)
>>dmesg output:
>>DVB: registering new adapter (Technotrend/Hauppauge PCI rev2.1).
>>DVB: AV7111(0) - firm f0240009, rtsl b0250018, vid 71010068, app 8000261c
>>DVB: AV7111(0) - firmware supports CI link layer interface
>>DVB: VES1820(0): setup for tuner sp5659c
>>DVB: VES1820(0): pwm=0x00
>>DVB: registering frontend 0:0 (VES1820 based DVB-C frontend)...
>>using dvb-apps/util/scan give me a channels.conf (i find almost every
>>channel...read somewhere that i should check some timeouts to get a
>>better scan result)
>>using same channels.conf as input for czap and i get:
>>[mythtv at localhost szap]$ ./czap -c channels.conf RTL -r
>>using '/dev/dvb/adapter0/frontend0' and '/dev/dvb/adapter0/demux0'
>>23 RTL:274000000:INVERSION_AUTO:6875000:FEC_AUTO:QAM_64:1100:1101:207
>>23 RTL: f 274000000, s 6875000, i 2, fec 9, qam 3, v 0x44c, a 0x44d
>>status 1f | signal b0b0 | snr efef | ber 009ffff6 | unc ffffffff |
>>status 1f | signal ffff | snr f0f0 | ber 009ffff6 | unc 00000000 |
>>status 1f | signal ffff | snr efef | ber 009ffff6 | unc 00000000 |
>>(status tells me i got good signal, little noise and that there is data
>>on vdr0, trying to just do cat /dev/dvb/..../vdr0 gives output)
>>then i try to view the stream in mplayer and nothing happens...see below.
>>i've also tried xine and did not get a picture there either.
>>[mythtv]$ mplayer - < /dev/dvb/adapter0/dvr0
> I have never tried piping the output from the dvb device straight into mplayer 
> but is suspect it will not work. Try using dvbstream and pipe it's output to 
> mplayer, this works for me:
> dvbstream -o -ps -qam 64 512 650 1590 | mplayer -
> you will of course need to substitute the appropriate pids for you station 
> (use scan -c to get the list of available pids)
> Cheers,
> Mark
> _______________________________________________
> mythtv-users mailing list
> mythtv-users at mythtv.org
> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users
Hi there - just been through the DVB-T route on FC3 - one thing you must 
do is not use the MAKEDEV-DVB.sh script - as FC3 uses udev.  Read the 
file udev.txt in the dvb-kernel cvs - 
/DOWNLOAD-DIR/dvb-cvs/dvb-kernel/linux/Documentation/dvb/udev.txt - that 
tells you how to setup udev to setup the device correct - otherwise it 
won't play fair.

Hope that helps,



More information about the mythtv-users mailing list