[mythtv-users] Nvidia DVI vs ATI

Brad Templeton brad+myth at templetons.com
Sat Dec 18 19:34:42 UTC 2004

On Sat, Dec 18, 2004 at 06:20:38PM +0000, Simon Williams wrote:
> The image the DVI-D connection produces ( valid modeline ) appears as
> if the interlaced fields are shifted vertically out of alignment. With
> one field displaying 10-15 lines higher than the other.
> On my search for a card that will do 1080i via DVI-D I can across the
> SIS chipset which has some excellent drivers provided by Thomas
> Winishhofer ( http://www.winischhofer.at/linuxsisvga.shtml ) his
> driver has in-built modelines for this purpose. Tracking down an SiS
> card with DVI is however proving to be a challenge.

Finally, after I ask in 1000 places and nobody knows a thing about it,
somebody has the same problem I have had with the FX5200 and a DVD

However, what made me beat my head for a long time was that I was
able to get the card to display 1080i over DVI to my HDTV under Windows 
using the Powerstrip program.   So it is _possible_ to get the card
to do this, but it does not seem to be doable under linux.

You want DVI on a card, it does seem the most common choices are NVidia
(with this problem) or ATI (with major driver problems and possible
inability to do xvideo at more than 1600 wide).   I have a number-9 DVI
card using a Savage chipset, but it is, alas, the old 3.5 AGP and
I can't plug it into any of the systems I have which are fast enough
to do HDTV.

The SIS drivers you point to do not mention xvmc.  I guess I don't
need it with the 3ghz CPU, but it would still be nice.

The question is, is it only the 5200 that has this DVI problem?  Have
people seen or not seen it with other NVidia chips, such as MX4000,
MX400 series, or higher end NVidia?  It seems a waste to buy a fancy
gamer's vga card and not use any of it.

Shuttle sells a cheap ($20) DVI adapter card for their systems that
use the Sis 315 chipset.  It fits in their AGP slot, but I am not sure,
is it an actual video card, or is it just an adapter that talks to the
chipset on the Shuttle XPC motherboard.  It also has TV-out.

It scares me though because it says "Max Resolution 1280x1024"

I ended up solving my problem the hard way -- with the audio authority
VGA to DVI converter.  It works, but due to going analog there is some

There is an MX4000 card with DVI out for $42 at buy.com, but I have had
other bad luck with the blue xvideo bug on the mx4000.

Also seen a Volari V3 card for $45 at Tiger Direct, anybody tried that.

More information about the mythtv-users mailing list