[mythtv-users] MythTV refuses to change channel/Problems with modprobe

Craig H Fry craigfry at mailsnare.net
Mon Dec 6 05:32:27 UTC 2004

I'm at my whits ends here.  I've reinstalled Fedora 3 times now and have 
gone through Mr. Wilson's guide everytime to the letter. 

Everything works fine (remote, picture, capture, etc) unless I reboot 
the system.  Then I can never get everything back and working again.  
Both the lirc and ivtv will not load.  I have to depmod -a and modprobe 
ivtv to get a picture back.  Then it mutes the card so I have to 
/usr/bin/ivtvctl -y mute=0 to get sound.  If I run 
/usr/lib/ivtv/ptune-ui.pl & mplayer /dev/video0 I can change channels on 
the card.  But on MythTV it will not change the channels at all.

Kernel: 2.6.9-1.681_FC3 (from http://www.atrpms.net/)


My modprobe.conf:
alias char-major-61 lirc_i2c
alias eth0 via-rhine
alias snd-card-0 snd-via82xx
options snd-card-0 index=0
install snd-via82xx /sbin/modprobe --ignore-install snd-via82xx && 
/usr/sbin/alsactl restore >/dev/null 2>&1 || :
remove snd-via82xx { /usr/sbin/alsactl store >/dev/null 2>&1 || : ; }; 
/sbin/modprobe -r --ignore-remove snd-via82xx
alias usb-controller ehci-hcd
alias usb-controller1 uhci-hcd
# nvidia kernel module
alias char-major-195 nvidia-1_0-6629
# ivtv modules setup
alias char-major-81 videodev
alias char-major-81-0 ivtv
options ivtv mpg_buffers=90
options tuner type=2
install lirc_i2c /sbin/modprobe ivtv; /sbin/modprobe --ignore-install 

I could care less about the remote at this point.  I just want my MythTV 
back and operational.  Any help would be greatly appreciated.

No virus found in this outgoing message.
Checked by AVG Anti-Virus.
Version: 7.0.289 / Virus Database: 265.4.5 - Release Date: 12/3/2004

More information about the mythtv-users mailing list