[mythtv-users] No xfs support in kernel 2.4.22-1.2199.nptl

Joseph A. Caputo jcaputo1 at comcast.net
Tue Aug 24 12:04:40 EDT 2004

On Tuesday 24 August 2004 09:59, Verteiler wrote:
> Hi,
> Another problem came up today when I tried to format a partition
> using the xfs-filesystem (following Jarod's how-to
> (http://wilsonet.com/mythtv/fcmyth.php#dedicated)). I patched the
> kernel using:
> # apt-get install kernel#2.4.22-1.2197.nptl_51.rhfc1.at
> # apt-get install kernel-source#2.4.22-1.2197.nptl_51.rhfc1.at
> (which worked fine), but when I tried to patch the kernel for nVidia
> support using
> # apt-get install
> kernel-module-nvidia-graphics6106-2.4.22-1.2197.nptl_51.rhfc1.at
> all it came up with was some error of not beeing able to find the
> module. After a rpm-search I found the appropriate rpm
> (ftp://ftp.pbone.net/mirror/atrpms.physik.fu-berlin.de/dist/fc1/nvidi
>a-graphics/nvidia-graphics6106-1.0_6106-60.rhfc1.at.src.rpm ) and
> installed it using rpm:
> # rpm -i nvidia-graphics6106-1.0_6106-60.rhfc1.at.src.rpm
> After this I could complete the kernel patch using Jarod's know how:
> # apt-get install nvidia-graphics6106
> Now my kernel boasts (?!) this description:
> 2.4.22-1.2199.nptl
> And this kernel does not has xfs support. How do I get the xfs
> support? Or did I make a mistake?

You're booting the wrong kernel.
Also, you need to install the latest ATrpms kernel.  Last time I 
checked, 2197 had been superseded by 2199.  Kernel modules on ATrpms 
are only maintained for the current kernel version, which is why it 
couldn't find the nvidia kernel module for the 2197 kernel.

Also, there is a newer Nvidia driver out.  6106 has been replaced by 

The 2199 kernel you are running is probably the stock Fedora kernel, 
which isn't patched for XFS; one of your 'apt-get's must have installed 
it.  Try doing:

apt-get install kernel#2.4.22-1.2199.nptl_52.rhfc1.at
apt-get install kernel-source#2.4.22-1.2199.nptl_52.rhfc1.at
apt-get install 

Also, after you 'apt-get' a new kernel, you'll want to make it the 
default kernel to boot n /boot/grub/grub.conf.


More information about the mythtv-users mailing list