[mythtv-users] Re: MPEG2 cutting script complete

Gavin Hurlbut gjhurlbu+mythtv-users at beirdo.ca
Mon Aug 23 11:25:09 EDT 2004


James L. Paul <james at mauiguru.com> wrote:
> I updated to the latest, 0.6.12, directly from the project site.

Sounds good.

> Filename "/opt/mythtv//1070_20040730160000_20040730170000.nuv"
> OutFile "Great Biker Build-Off - Russ Mitchell vs. Eddie Trotta.mpg"
> Last GOP index 7187
> Cutlist "-19059 22666-24851 31237-51762 57767-72955 80824-93036 103157-106890 
> 107802-"
> Finding the AV Offset to use with lvemux:0
> Finding framerate:29.970
> Last Frame 107805
> Indexing the file with avidemux2
> Cutting out commercials with avidemux2
> /usr/local/bin/mpeg2cut: line 117: 10273 Aborted                 nice -n 19 
> avidemux2 --load-workbench ${BASENAME}.cut --audio-codec MP2 --save-raw-video 
> ${BASENAME}.m2v --save-raw-audio ${BASENAME}.mp2 --quit 2>/dev/null 
>>/dev/null
> Remultiplexing video
> GOP timestamps will be rebuild
> ERROR: opening A/V streams (0/1)
> Cleaning up
> rm: cannot lstat `1070_20040730160000_20040730170000.mp2': No such file or 
> directory

OK.  This is avidemux2 crashing on your audio stream, obviously.  Now what's
causing that...  Hmmm.

I guess the first thing to ask: what version of avidemux2?  2.0.26 has some
known issues with MPEG2 stuff, so if that's your revision, upgrade to 2.0.28
or downgrade to 2.0.24 and try again :)

> I haven't dug into this further yet to find out why can't open the A/V streams 
> and breaks, but it's certainly not working for me.

If you could come on IRC tonight, I might be able to do some online
troubleshooting with you.  It's awefully hard to do over email as it can take
several iterations.


Ciao
Gavin


More information about the mythtv-users mailing list