[mythtv-users] [CVS: Jul 23/24] Jump Ahead causes video freeze -- new vsync code?

David George david at thegeorges.us
Fri Aug 20 08:29:28 EDT 2004

[Please excuse major trimming.  Refer to previous messages in this 
thread for more details.]

On 8/20/2004 1:48 AM, John Patrick Poet wrote:

> John Patrick Poet wrote:
>> Awsome!  This patch fixed the problem for me.
>> Even after this patch, I was still getting it to "Aborted" 
>> occationally, but a "make distclean;make;make install" seems to have 
>> fixed that.
>> Thank you!
>> John
>> P.S.  What are you using for a soundcard?  I am using an old SB 
>> Live!  I tried using the onboard S/PDIF, but it caused an occational 
>> crackel in the sound.
> I spoke too soon with regards the "Aborted" problem.  I cannot 
> consistanty get it to Abort, but it still happens a lot -- probably an 
> average of 1 out of every 8 times I do a 30 second JUMP.  Sometimes it 
> segfaults instead of Aborts, but it is always right after doing a 
> JUMP.  What is really bad, is that about one out of every dozen times 
> the frontend dies like this, it takes the backend with it:
> QSocketDevice::writeBlock: Invalid socket
> QSocketDevice::writeBlock: Invalid socket
> 2004-08-19 22:40:03 WriteBlock(): Aborting WriteBlock, write to socket 
> failed!
> I always get the above message when the frontend dies, but sometimes 
> the backend will be dead after generating those messages.
> It looks like the frontend is dieing in the ALSA library, from a call 
> in audiooutputalsa.cpp -> getSpaceOnSoundcard -> snd_pcm_delay.  At 
> least that is where it had died the time I finally got a usable 
> stack.  Sort of looks like it is trying to re-initialize the audio.

Hmm, can you email me this.

> I noticed that there is a new verison of ALSA available (1.0.6).  I 
> was/am using 1.0.5.
> I tried upgrading to 1.0.6, but that version has serious audio 
> problems for me.  Any audio played with 1.0.6 cuts in/out/in/out very 
> rapidly.  So I went back to 1.0.5.

I am alsa on the alsa list and there are a few issues with the 1.0.6 
release, hopefully they will issue another new release soon.  I was 
thinking about trying out the alsa CVS, but time has been limited lately.

> Next I tried switching to OSS emulation.  That seems to have fixed the 
> Aborted/Segfault problem, but does not recover from the 30 second 
> JUMPs as well.  With ALSA, there anywhere from zero to 1 second of 
> stuttering after each JUMP.  With OSS emulation, there is anywhere 
> from .5 to 3 seconds of stuttering after each JUMP.  At least it does 
> not cause the frontend to die, so I guess I will live with the 3 
> seconds of stuttering for now.
> When I have some more time to look at it, I will try and figure out 
> why the ALSA code is so fragile.  Unless David George figures it out 
> for me ;-)

I haven't noticed this myself, but I haven't had much time to watch TV.  
I should be able to look into this Sat and/or Sun afternoon.  I will try 
jumping forward on my system and try to duplicate.  I am currently using 
the onboard sound, but I have a couple SB Live! I could try.

> Thanks for your help, Doug.
> John


More information about the mythtv-users mailing list