[mythtv-users] Setting up Microtune FM4045 tuner

Hamish Tweedie hamish at hamishtweedie.com
Sat Aug 7 08:57:30 EDT 2004


  I cant seem to get a microtune 4045 tuner set up and working on my
  FC1 machine that has been set up according to Jarods guide.

  I am in a PAL B/G country and have successfully had a PAL I PVR350
  running under the standard ivtv 1.9 RPM from Axel (apart from the fact
  that the picture/sound is off syncing using a PAL I card with a B/G
  signal). To solve this Ive bought a new I/B/G/Secam PVR 350 which has
  a Microtune FM4045 tuner on it.

  Ive upgraded ivtv to the 1.10-40_pre2_ck100m version (again using
  Axels RPMs). My module.conf file has the following relevant lines:

# ivtv stuff
alias char-major-81 videodev
alias char-major-81-0 ivtv
alias /dev/v4l ivtv
options tuner pal=b debug=1
options ivtv ivtv_debug=1 ivtv_std=2 tuner=45 tda9887=0
options tda9887 debug=1
options saa7115 debug=1
options saa7127 debug=1 enable_output=1 output_select=0 pal=1
options msp3400 debug=1 once=0 simpler=1 simple=0 standard=0x08
add below ivtv msp3400 saa7115 saa7127 tuner tda9887
add above ivtv lirc_dev lirc_i2c #ivtv-fb

  With this I then do a:

/sbin/depmod -a
/sbin/modprobe ivtv
/sbin/modprobe v4l1-compat

  And then run a short script to set the channel and parameters
  consisting of:

/usr/bin/ivtvctl --device=/dev/video0 -u 0xff
/usr/bin/ivtvctl --device=/dev/video0 -p 5  # Have also tried 4
/usr/bin/ivtvctl --device=/dev/video0 -f width=720,height=576
#/usr/bin/ivtvctl --device=/dev/video0 -v input=3,output=1 # Cant seem
to find a ivtvctl alternative to this ioctl command!!
/usr/bin/ivtvctl --device=/dev/video0 --set-freq=10472

  ivtv seems to load up okay (/bin/dmesg reports ivtv loads okay). When
  I try and capture some video using cat /dev/video0 >
  /tmp/test_capture.mpg a capture occurs but it is just a black screen.
  Given that this is occuring I assume somehow its grabbing from the
  wrong input source, but Im stuck as to how to correct this (Ive
  tried using alternative inputs via the ivtvctl -p command but to no
  avail).

  Is anybody able to run their eye over the above and let me know where
  Im going right or wrong as Im finding the lack of documentation for
  this version a little difficult!

  Many thanks in advance ...


More information about the mythtv-users mailing list