[mythtv-users] Problem found - Watch recordings not working

Michael J. Lynch mlynch at gcom.com
Wed Aug 4 15:59:08 EDT 2004

RHFC2 users beware.  Yoy may run into this problem.  See bug report below:


Michael J. Lynch wrote:

> Hi list,
> The problem I am having is I get a blank screen when I go to watch a 
> recording in full screen mode.  Watching live TV in full screen mode 
> works just fine.  When I use "watch recordings", the screen is blank 
> and sound is working but I noticed that I'm getting the following 
> message in the terminal window from which I ran mythfrontend.
>    X Error: BadAlloc (insufficient resources for operation) 11
>    Major opcode: 141
>    Minor opcode: 19
>    Resource id: 0x2a0000
> So I figure this has something to do with the problem. Since the 
> preview on the "watch recordings" screen was working I decided to try 
> setting the GUI size to something smaller than full screen. At about 
> 300x300 GUI size, playback started working and the error message went 
> away. Going back to full screen made the error return so I reset back 
> to the working GUI size.
> Next, since recording was only taking up 40% of my processor, I 
> increased the capture size from 480x240 to 480x480 using the MPEG4 
> encoder with a bit rate of 5500. This put me at about 11% idle while 
> recording. Using the 300x300 GUI size, I tried to playback a recording 
> and once again the error message appeared. I lowered the GUI size some 
> more and everything started working again. It appears that there is 
> some sort of inverse relationship between the capture size and 
> playback size that determines whether or not the problem occurs.  The 
> strange thing is this is NOT so with "Watch Live TV".  Full screen 
> mode works just fine with that.  So far, the only way I've been able 
> to get full screen playback to work it to use an unacceptably low 
> capture resolution.
> Following a suggestion from a reply to someone else who is 
> experiencing a similar problem, I set the NO_XV environment variable 
> to 1 and see what effect that had on the frontend. Wow...playback in 
> full screen mode worked but pegged my processor (as the reply 
> indicated it would do). The reply suggested that if things worked with 
> no xv, that the problem may be related to the video card/driver xv 
> support.
> My system is a Compaq Deskpro EN SFF with a 733 Mhz P3 (near silent 
> machine), 384M, 40G, WinTV card. I'm using the onboard Intel 810 
> video. The system is running Redhat Fedora Core 2 with Myth 0.15.1.
> Can anyone verify that the problem is, in fact, a problem with xv 
> support for the Intel 810 and, if so, suggest an inexpensive 
> replacement to use in it's place?
> Thanks in advance for any information and/or suggestions anyone may have.
> _______________________________________________
> mythtv-users mailing list
> mythtv-users at mythtv.org
> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users

Michael J. Lynch
Gcom Inc.

"What if the hokey-pokey IS what it's
all about?" -- author unknown

More information about the mythtv-users mailing list