[mythtv-users] Free USB RF remote (just $5.90 for shipping)

Kristo Kriechbaum klk+myth at robotics.caltech.edu
Tue Apr 27 00:18:17 EDT 2004

On Mon, Apr 26, 2004 at 12:01:57PM -0700, Dex West wrote:
> --- Kristo Kriechbaum <klk+myth at robotics.caltech.edu> wrote:
> > So I got my "x10 lola" remote yesterday.  Trying to figure out how
> > to scrape off that stupid logo without scratching the hell out of
> > it.
> > 
> > I'm running:
> > kernel 2.4.22-1.2179.nptl_47.rhfc1.at, 
> > lirc-0.7.0-20_cvs20040208.rhfc1.at, and
> > lirc-kmdl-2.4.22-1.2179.nptl_47.rhfc1.at-0.7.0-20_cvs20040208.rhfc1.at
> > 
> > all from atrpms.
> I've worked all weekend trying to get lirc to work.  I've grabbed
> all three items above.  Did you have to compile the lirc source?

I did not compile anything from source.  'apt-get install' the above 3
was all I did.

> Did you add something to the module.conf to get lircd running?  

I did not add anything to my modules.conf.  I belive that since the
reciver is usb, it gets automagically detected, and it knows the
correct module to load.

> From what I understand at this point based on reading the
> documentation you need to compile source, install source, and then
> configure module.conf to load the lircd based on a precompiled
> driver (i.e. serial, or other).  

lircd is the program you run that talks to the remote.  In some cases
you may have to add something to modules.conf, for example if you have
a serial reciver.  But I didn't.

> > When I plugged in the reciever, it just worked.  It loaded the
> > lirc_atiusb module.
> What is "it loaded the lirc_atiusb module" mean?  I've found the
> atiusb source directory under remotes, but don't have a driver file.

After I plugged in the reciver, 'lsmod' showed the following:

      Module                  Size  Used by    Not tainted
      lirc_atiusb             7132   0 (unused)
      lirc_dev                9840   1 [lirc_atiusb]
      (lots of other modules follow)

if lsmod is not in your path, you may have to try '/sbin/lsmod'.

Once the module is loaded, you will have to run 'lircd'.  Mine is in
/usr/sbin/lircd, but if you aren't using the packages from atrpms,
yours may be in a different location.  After you run lircd, you should
run 'irw'.  When that is running you can press keys on your remote and
the output will show you what keys are pressed.

Good luck,

More information about the mythtv-users mailing list