[mythtv-users] Free USB RF remote (just $5.90 for shipping) - Getting it to work

Clint Gilders techservices at onlinehobbyist.com
Wed Apr 21 09:11:34 EDT 2004

Brian Rumple wrote:
> Here are the things you will need to get.  I think everything should be
> pretty straight forward.  Wish handles all the communication with the
> transceiver.  For the remote buttons it goes through the /dev/x10/remote
> device.  All other X10 commands go through wish's /dev/x10/a1,
> /dev/x10/a2, etc.  So if you have X10 device you can control them also.
> Wish has a script called makedev.sh that will create all the devices for
> you.  If you don't care about X10 commands you could just do:
> mknod /dev/x10/remote c 121 80
> I never do a make install on wish.  For my kernel I just do:
> mkdir /lib/modules/2.4.25/kernel/drivers/char/x10
> cp x10_fcusb.o /lib/modules/2.4.25/kernel/drivers/char/x10
> depmod -a
> modprobe x10_fcusb
> The module loading will hang if you don't have the transceiver plugged
> in.
> http://prdownloads.sourceforge.net/wish/wish-1.6.9a.tar.gz?download
> http://home.comcast.net/~brumple/fcusb.diff
> http://home.comcast.net/~brumple/MouseRemoteFC.pl
> http://home.comcast.net/~brumple/MouseRemoteFC.conf
> http://home.comcast.net/~brumple/MouseRemoteKeys.pl

Thanks for the files.

I received my free remote today.   I have built and installed the driver 
on my Mandrake 9.2 system for testing before I try it on my myth box.

I followed the steps above, and everything went fine.  Now what do I do? 
  I've run MouseRemoteFC.pl and it reports the key presses I make but 
that's it.  When run with debugging I see (when pressing the power 
button for example):

 >> 4 Length
 >> 02 Device:
 >> 08 Device:
 >> 7F Device:
 >> 80 Device:
byte = 2 code = 128
undefined key:02 for
Eating key 02
Eating key 02
Eating key 02
Eating key 02

Since myth isn't on this machine I changed the Power entry in 
MouseRemoteFC.conf to:

power /usr/bin/xmms

Still nothing.

With many of the entries I see references to 'xte':

0 xte 'key 0'
1 xte 'key 1'
2 xte 'key 2'
3 xte 'key 3'
4 xte 'key 4'
5 xte 'key 5'

Is 'xte' a program that I should have?   Where would I find it?

What I did do to make sure the remote itself worked was download the 
original versions of the MouseRemote.pl et. al. and hacked them a bit to 
work with the Lola remote.   Using those scripts I can run commands just 
fine.  This is what I see when I run the daemon and press power:

[clint at monster client]$ perl MouseRemote.pl -d PC
 >> 02 Device:PC
byte = 2 code = 128
/usr/bin/xmms --Eating key 02
Eating key 02
Eating key 02
Eating key 02

How do I send keypresses so I can control a myth frontend?   Is that 
what xte is for?
Clint Gilders <techservices at onlinehobbyist.com>
Director of Technology Services
OnlineHobbyist.com, Inc.

More information about the mythtv-users mailing list