[mythtv-users] More LIRC Woes

Michael T. Dean mtdean at thirdcontact.com
Mon Apr 19 17:11:45 EDT 2004

Scott Nicholson wrote:

>When I run mode2 (I'm logged in via ssh) I get:
>This program is only intended for receivers supporting the pulse/space
>Note that this is no error, but this program simply makes no sense for your
>In order to test your setup run lircd with the --nodaemon option and
>then check if the remote works with the irw tool.
>I then went to the box itself and tried xmode2 with the same result.
>Does this mean I've got something configured wrong?
Sounds like lircd is using the wrong driver--which means you probably 
have a LIRC installation that was compiled with "--driver=any".  Try 
starting lircd with:

lircd --driver=serial

or, in your case, probably you can add "--driver=serial" to LIRCD_OPTS 
in /etc/conf.d/lircd.  (If you prefer short options, use "-H serial" 
instead.)  See man lircd for details.

You can get a list of drivers supported by your installation of LIRC by 
specifying an invalid driver name, i.e.:

lircd --driver=help



More information about the mythtv-users mailing list