[mythtv-users] ALSA and SPDIF Out For nForce2 Motherboards

KianTeck chua_kianteck at yahoo.co.uk
Sat Apr 17 21:16:43 EDT 2004

Michael T. Dean wrote:

> KianTeck wrote:
>> From the mythfrontend, this is what it says when I tried to switch 
>> over to watch live TV:
>> --------------<snip>---------------
>> Opening ALSA audio device 'digital'.
>> ALSA lib pcm_hw.c:1057:(snd_pcm_hw_open) open /dev/snd/pcmC0D2p 
>> failed: Device or resource busy
>> Playback open error: Device or resource busy
>> 2004-04-17 23:28:31 Using XV port 105
>> --------------<snip>---------------
> That seems to indicate that some other program is using your sound 
> device.  Since you've set a default of "unmixed" digital, only one 
> process can use the sound at a time.  It seems Myth won't do playback 
> if it cannot get access to the sound device (which is exactly what it 
> should do).
> Therefore, try "mixed" digital as your default.  Uncomment this line 
> instead:
> ## Uncomment the following to use mixed digital by default
> #  slave.pcm "dmix-digital"
> Note, you will need to restart the program that is currently using 
> your sound before this will take effect (because it is still using it 
> exclusively).  The easiest way to ensure this happens is probably to 
> reboot after changing your .asoundrc.
Did as advised: commented out the slave.pcm  "digital" and removed the 
comment  for slave.pcm  "dmix-digital".  I then made the change in 
MythTV from "ALSA:digital" to "ALSA:dmix-digital" for the "Audio output 
device".  Rebooted the machine but still no joy.  I'm able to get sound 
out via the analog output if I change "Audio output device" back to 
default of "/dev/dsp".

Please help.  This ALSA to SPDIF is making me going crazy.


More information about the mythtv-users mailing list