[mythtv-users] Need help with native lirc

Joseph A. Caputo jcaputo1 at comcast.net
Wed Apr 14 17:10:25 EDT 2004

On Wednesday 14 April 2004 15:31, John W. Ross wrote:
> >Date: Wed, 14 Apr 2004 10:08:05 -0400
> >From: "Harry Orenstein" <ho_9 at hotmail.com>
> >Subject: RE: [mythtv-users] Need help with native lirc
> >To: mythtv-users at mythtv.org
> >Message-ID: <BAY14-F14rttDRdNOUi0004bb36 at hotmail.com>
> >Content-Type: text/plain; format=flowed
> >
> >>Hello,
> >>
> >>I've been using MythTV for quite sometime and just recently decided
> >> to
> also
> >>begin running Mythvideo and MythDVD.  So... irxevent control is no
> >> longer able to cover my needs for remote.  If I run video or dvd,
> >> as I leave the playback the focus is not returned to Myth.  Since
> >> my frontends (4 frontends - 2 backends) do not have keyboards or
> >> mice, I cannot regain control of the machine.  As I said, lirc
> >> with irxevent is working fine for me.  But after recompiling with
> >> native lirc I have no joy.  Naturally I'm no
> >>longer starting irxevent &.  Lirc is started as per the MythTV
> >> howto in my rc.local file.  MythTV is started with the following
> >> script
> >>
> >>killall mythfrontend
> >>killall irxevent
> >>mythfrontend -l /home/myth/mythfrontlog.txt
> >>
> >>which exists as mythtv.sh in my .kde/Autostart directory.
> >>
> >>In the log for the frontend I get:
> >>
> >>2004-04-13 21:05:21 Enabled verbose msgs : important general
> >>mythtv: could not connect to socket
> >>mythtv: No such file or directory
> >>lirc_init failed for mythtv, see preceding messages
> >>2004-04-13 21:05:23 Registering Internal as a media playback
> >> plugin.
> >>
> >>And of course it does not operate.  I have gone to /dev and have
> >> set lirc, lircd and even lircm to 0777 (yes 777 since 666 wasn't
> >> working and I don't see the need for "security" on a machine that
> >> only operates as a mythfrontend).
> >>
> >>
> >>I've seen similar questions before on the list, but I've not found
> >> any solutions from searching the archive.  Has anyone got a
> >> suggestion?
> >>
> >>Thanks,
> >>John
> >
> >It looks like you've got problems with Myth connecting to the LIRC
> >driver, but I also noticed that you indicate that you are using
> > .lircrc for a config file.  Myth uses ~/.mythtv/lircrc (you said
> > you read the howto, see:
> > http://www.mythtv.org/docs/mythtv-HOWTO-22.html#ss22.2).
> >
> >I would try doing everything manually before I tried setting up the
> >daemon to run from rc.local (not how I would do it, but to each
> > their own).  Manually start the daemon, manually start Myth's
> > backend, test with irw and then manually start Myth's frontend (not
> > via .kde/Autostart). If irw worked you should see a socket connect
> > message in syslog.  After starting the frontend you should see a
> > similar socket connect (or socket error) message in syslog.  You
> > may also want to make sure that you don't have any variant versions
> > of the LIRC library.  If you loaded LIRC from RPM and compiled Myth
> > that could be your problem.
> >
> >Hope I've given you some ideas.  Let me know how it works out.
> >
> >
> >-- Harry O.
> Definitely helpful.  I have now moved the lircrc to
> /home/myth/.mythtv/lircrc.  Unfortunately this didn't fix the issue
> but it was certainly an oversite on my part.  You know I ever re-read
> that section last evening and could remember the passage.  I had
> mentally transposed the text to "Notice the .lircrc not lircrc" 100%
> wrong.  Thanks.
> You are also right, I was hoping this would be something I could fix
> quickly without having to attach keyboard/mouse/monitor.  Oddly I'm
> not getting anything in my syslog at all regarding connects.  I can
> start irw and get the responses on screen but upon checking syslog
> there is nothing there regarding lirc/irw.  There has never been
> anything in my syslog regarding mythfrontend.  Now I don't want to be
> stupid here... but I don't have to run the backend for native lirc to
> work do I?
> Also, I'm running Mandrake 9.2 but lirc and all myth modules are
> compiled from source.  Also, the machines are all bare metal builds
> (I will hack this until I have a total install script that does
> everything for me, then I'll walk away for a couple of hours and come
> back to test).  There are urpmi pacakges used, but only for
> prerequisites.
> Thanks for your help Harry and to Joseph A. Caputo, wish the lircrc
> was the problem.  Well wait one more thought.  I can't start lircd as
> myth even if I take it out of my rc.local myth can't start it, I have
> to go to root to start the daemon. Now this didn't have an effect on
> irxevent or on irw, but could the lircd process belonging to root be
> a problem? I'm gonna keep plugging on it, thanks guys.

Starting lircd as root is OK; the only permissions that matter to a LIRC 
client process are the perms on /dev/lircd.  Some distros put this in 
"/tmp" instead of "/dev", so double-check.  Are the error messages from 
the frontend now *exactly* the same after moving your .lircrc to 
~/.mythtv/lircrc ?


More information about the mythtv-users mailing list