[mythtv-users] Setup program freezes X

Hans-Christian Prytz hcp_public at prytz.net
Tue Apr 6 04:38:47 EDT 2004

Hans-Christian Prytz wrote:

> Hi, I'm having a lot of trouble with 0.14, more specifically with the 
> setup program.
> When I start it, it works for 5-30 seconds, then it freezes the whole 
> console of the macine (ie. only way to reach the machine is via ssh).

(oops, seems like I forgotr to mention that this is a Nvidia based 
system. Graphics card is FX5200)

After some more testing, I now have the following situation:
1. Turning off AGP (Option "NvAGP" "0" in XF86Config) removes the 
"Badness....." errors ("Unknown Key..." is still there, don't know what 
this is)

2. Using other things on the display works fine. F.eks. watching a movie 
(several actually) with mplayer (xv output) has no problems.

3. Running Mythtv setup program exported to another display works fine.

4. Tried to run mythfrontend (on the local tv display) (to check whether 
there is something bad in just the setup prog) gives the same result. 
Total hang within ~30 seconds. Note. this happens when I'm only in the 
frontend gui, I have not tried to play any video.

This is a gentoo system, and the version numbers of relevant software is:
Qt: x11-libs/qt 3.3.0-r1
Xfree: 4.3.0-r5
Mythtv: 0.14 (from the website)
Nvidia gfx driver: 4363 with minion.de patches for 2.6
Kernel: sys-kernel/development-sources 2.6.4 (ie. vanilla kernel.org 
sources patched with ivtv patches)

Hmm, can't think of anything else for now.

Oh, the "Unknown key..." messages in syslog happen as X is started, and 
don't seem to be related to Myth at all.

If anyone has any suggestions, I'd be grateful.


More information about the mythtv-users mailing list