[mythtv-users] Dual tuner capture works, but not in Myth

Nate Thompson natet at buckeye-express.com
Sun Apr 4 19:15:38 EDT 2004

I've been working through some bugs with ivtv to get both of my PVR-250 MCE
cards (one revision one, the other a revision two) to work in MythTV. I can
do a 'cat /dev/video# > /tmp/video#.mpg' (# = 0 or 1) and capture audio and
video. However, when I try to use the second tuner in MythTV, either with
PiP functions, or watching a live broadcast while another is recording, I
get a couple errors. I get a couple messages saying 'taking too long to be
allowed to read..' followed by 'waited 2 seconds for data to become
available, waiting again.' and finally 'Couldn't read file:
rbuf://'. After that, MythTV
quits responding to keypresses and I have to kill the frontend process.
Looking at the dmesg output, there are a bunch of 'ivtv: Timeout waiting for
data!' errors. Those also show up in /var/logs/messages.

I am using a patched version of ivtv 0.1.10pre2 (ck05 available here -
http://kmos.org/~ckennedy/ivtv/ivtv-0.1.10-pre2-ck05.tgz). I was originally
using 0.1.9 with one tuner card without problems, but had to upgrade to
0.1.10 because the older version would not correctly identify my revision
two PVR-250. Any insight into this would be apprechiated. This question
might be better asked on the ivtv mailing list but I thought I'd see if
someone here has had a similar experience that they were able to work

Nate Thompson

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mythtv.org/pipermail/mythtv-users/attachments/20040404/29904a20/attachment.html

More information about the mythtv-users mailing list