[mythtv-users] This version of XMAME is not supported

Mike Jasper e394td at comcast.net
Sat Apr 3 13:59:45 EST 2004

Steve Dorsey wrote:
> Hello
>   I used Jarod's guide to install xmame, and I am getting a "This 
> version on xmame not supported" error when I try to run it. I checked 
> the settings for Mythgame, and I noticed that xmame installed in 
> /usr/share/xmame. I tried to fix all the paths in the options, but I'm 
> still getting the same error when I select "Games" fromt he main menu.
>   I searched the gossamer forums, and a lot of people are asking this 
> question, but no one seems to be offering answers. Has anyone figured 
> out how to resolve this?

This had me stumped for a little while.  Even after I had set all the 
correct paths in the settings, I was still getting that error.

1) Make sure you go into Setup > Game Settings > General Settings and 
define all of the appropriate paths and directories.  In your case the 
xmame *binary* will be /usr/bin/xmame, so make sure you get that 
correct.  It's the first setting in the list.  Most of the other paths 
will point to files and/or directories under /usr/share/xmame.

2) Copy some roms to /usr/share/xmame/roms.

3) Restart mythfrontend (important!).

4) Try again to go to Games and it should automatically scan for your 
roms instead of giving you that error.

Restarting mythfrontend is what finally made it work for me.  I should 
have thought of that sooner :-)

Hope that helps.

More information about the mythtv-users mailing list