[mythtv-users] btaudio problems

Chris cisip at sprintmail.com
Wed Mar 26 00:18:56 UTC 2003


I had a similar problem when I tried to get btaudio working. It tried to
grab the first dsp device (dsp or dsp0).  The way I fixed it is I
launced esd & first to lock the dsp device and then modprobe btaudio so
that it will grab /dev/dsp1 and /dev/dsp2. And then i killall esd to
free up /dev/dsp for mythtv.  Apparently, the ordering of the modules in
modules.conf does not affect which devices gets first access on which
dsp devices. Its which devices are called by which program first which
determines the assignment of the dsp devies.   Using this technique I
was able to assign sblive /dev/dsp0 , btaudio /dev/dsp1 and /dev/dsp2,
btaudio (for second tuner) /dev/dsp3 and /dev/dsp4, and then em300 for
/dev/dsp5.   I run these in rc.local.  Hope this helps.



On Tue, 2003-03-25 at 10:03, Unit3 wrote:
> I was going to send my dmesg and other output concerning working btaudio 
> setups, when I discovered mine no longer works! :(
> 
> I'd reinstalled my alsa modules, and now I only have one mixer device 
> (when once I had two), and I only have two dsp devices (when once I had 
> 3). Something is messed up here, and I can't track it down.
> 
> dmesg shows the following interesting tidbits:
> btaudio: driver version 0.7 loaded [digital+analog]
> btaudio: Bt878 (rev 17) at 00:0d.1, irq: 10, latency: 32, mmio: 0xdf001000
> btaudio: using card config "default"
> btaudio: registered device dsp0 [digital]
> btaudio: registered device dsp1 [analog]
> btaudio: registered device mixer0
> 
> however, in /dev/sound I have:
> crw-------    1 unit3    audio     14,   9 Dec 31  1969 dmmidi
> crw-------    1 unit3    audio     14,   3 Dec 31  1969 dsp
> crw-------    1 unit3    audio     14,  19 Dec 31  1969 dsp1
> crw-------    1 unit3    audio     14,   2 Dec 31  1969 midi00
> crw-------    1 unit3    audio     14,   0 Dec 31  1969 mixer
> 
> (unit3 is my currently logged in username)
> 
> Sound directed to "dsp" comes out my soundcard, so evidently "dsp0" has 
> disappeared into thin air. However, "mixer" belongs to btaudio 
> (according to the kmix display), and not to my soundblaster live!
> 
> In my /lib/modules/kernel/sound/oss, I have ALSA's snd-mixer-oss and 
> snd-pcm-oss, but for some reason these aren't getting loaded as the 
> /dev/mixer device, when they were before by Gentoo's /etc/modules.d/alsa 
> script.
> 
> Any ideas as to the cause of this problem would be *greatly* appreciated.
> 
> Graeme
> 
> _______________________________________________
> mythtv-users mailing list
> mythtv-users at snowman.net
> http://lists.snowman.net/cgi-bin/mailman/listinfo/mythtv-users
-- 
Chris <cisip at sprintmail.com>



More information about the mythtv-users mailing list