[mythtv-users] Weird Problem with Settings

Bruce Markey bjm at lvcm.com
Thu Mar 13 20:29:45 UTC 2003


Christopher Miles wrote:
> Hello,
> 
> I running MythTV from CVS under Gentoo linux. I am using a motherboard 
> with the NVIDIA nforce chipset and a Hauppage WinTV dbx 401 card. I have 
> the card wired to the CD port on my board to get the audio. Everything 
> seems to test out okay, but I can't seem to get audio working through 
> MythTV.
> 
> I believe that everything is setup okay in alsamixer. When I run xawtv I 
> can't hear the audio because the cd-in is muted. If I run "aplay 
> /dev/dsp" while running xawtv I can hear the audio through my external 
> speakers.
> 
> The backend application runs fine, but when the frontend starts I see this:
> 
>> connecting to backend server: 127.0.0.1:6543
>> Changing from None to WatchingLiveTV
>> player: Can't open audio device:
>> open audio:: No such file or directory
>> Over/underscanning. V: 0.050000, H: 0.050000, XOff: 0, YOff: 0
>> Using XV port 103
>> Unable to find font:
>> No OSD will be displayed.
> 
> 
> All of this information (audio device and font) is set in my 
> /usr/share/mythtv/settings.txt file, but it's as if it isn't getting 
> read. I checked the tables in MySQL and they appear to be setup 
> correctly. What really bothers me is the lack of a device listed after 
> the "open audio:: No such file or directory". Shouldn't it be listing 
> the device it's trying to open?
> 
> Should this file be somewhere else?

Your messages make it appearent that this is 0.8 (CVS) rather
than 0.7. In 0.8, all of this information is in the database.
Your backend settings are initialize when you run "setup".
After they are set, run the backend, the frontend, and go
through each of the "Setup" pages.

--  bjm




More information about the mythtv-users mailing list