[mythtv-theming] Mythvideo gallery view

Robert McNamara robert.mcnamara at gmail.com
Mon Jul 6 20:06:35 UTC 2009

On Mon, Jul 6, 2009 at 12:42 PM, Damian O'Sullivan<shabba at skynet.ie> wrote:
> On Mon, 6 Jul 2009, Robert McNamara wrote:
>> Whether it's supposed to be the case or not, it is definitely a
>> "known."  :)  Probably shouldn't be, though.
> "known" ? :-) I suppose no ticket then?

None that I know of-- I've spoken to Anduin about it before but was
never motivated enough to open a ticket.  It's very likely a simple
fix, I'd guess.

>> The "?" is actually an image, it's there because the State->buttonitem
>> image uses it.  Works great for a video with no image, not so well for
>> the upfolder state.  I worked around this by replacing the default
>> buttonimage with a nice linear gradient.  Attractive, and no ugly ?.
> I am curious as to why the .. does not use the folder.(jpg|gig|png) image
> like a regular dir? This would work fine as all my dirs have images.

This is probably a limitation of the "folder" hunt code.  I've
identified a few other weaknesses in it that I'd like to see fixed
too, but most of them involve getting MythVideo/SG directory
preferences working.

>> So, the long and short of it is you can remove that image by changing
>> the default filename for buttonimage to a null, or any other image you
>> like.  Better to leave it *some* image, though, so that there is a
>> placeholder when there's no cover art.
> Does the default image have that green arrow ? I would have though that was
> only for backup type button?

The green arrow should be from the "upfolder" state in the buttonlist.
(working from memory)

>>> Pic @ http://skynet.ie/~shabba/mythvideo.png
>> Looking good.
> Meeds your patches to be submitted :-). I don't wanna upgrade DB unless its
> official as it is my production box.

More information about the mythtv-theming mailing list