[mythtv-firehose] mythtv/master commit: 1f464e9cd by Michael T. Dean (sphery)

MythTV noreply at mythtv.org
Thu Feb 23 05:35:50 UTC 2012


      Author:  Michael T. Dean <mdean at mythtv.org>
 Change Date:  2012-02-22T21:35:06-08:00
   Push Date:  2012/02/22 21:35:33 -0800
  Repository:  mythtv
      Branch:  master
New Revision:  1f464e9cd2096387f629b4fb6c7e82fc5fc5478a
   Changeset:  https://github.com/MythTV/mythtv/commit/1f464e9cd

Log:

Ensure we use the right OpenGL libs.

After c5125787b , even though we're no longer compiling OpenGL ES
support when Qt wasn't compiled to use Qt, we were still linking OpenGL
ES libs on systems with OpenGL ES development packages installed.  This
change should ensure we use OpenGL ES libs only when using a Qt version
compiled against OpenGL ES, and use non-ES libs when using a Qt version
compiled against non-ES OpenGL.

This seems like it should work for all systems--Qt using OpenGL with
OpenGL installed on the system (regardless of whether OpenGL ES is
installed) or Qt using OpenGL ES with OpenGL ES installed (regardless of
whether non-ES OpenGL is installed)--but I haven't tested it on an
OpenGL ES compile, so please let me know if you encounter difficulties.

Refs #10336

Modified:

   mythtv/configure



More information about the mythtv-firehose mailing list