<div dir="ltr"><div dir="ltr"><div dir="ltr"><br></div><br><div class="gmail_quote"><div dir="ltr" class="gmail_attr">On Sun, 6 Feb 2022 at 12:36, John Pilkington <<a href="mailto:johnpilk222@gmail.com">johnpilk222@gmail.com</a>> wrote:<br></div><blockquote class="gmail_quote" style="margin:0px 0px 0px 0.8ex;border-left:1px solid rgb(204,204,204);padding-left:1ex">On 06/02/2022 10:40, Klaas de Waal wrote:<br>
> Hi,<br>
> <br>
> I have now on two different systems that the checkbox for "This server <br>
> is the Master Backend" is unexpectedly unchecked. This is with testing <br>
> the fixes/32. It could just be that I did something wrong but if others <br>
> also experience this issue it might be a bug.<br>
> <br>
> Klaas.<br>
<br>
I have mythtv-setup problems too, but thought they were caused by <br>
unwanted interaction between boxes intended to be independent.  At <br>
present I have switched off the problem box and am wondering if I need a <br>
DB restore.    I dislike the full-screen arrogance of the default setup, <br>
and that it finds several servers with no obvious way of knowing which <br>
is which.   Fortunately, once set up, it usually works.  And I know I'm <br>
supposed to use the 'ten foot interface' model with a single syatem...<br><br></blockquote><div>My problems did start after trying to test an updated Dutch translation on my laptop.</div><div>It looks like starting mythfrontend with the -p command line option, as recommended in the Wiki page <a href="https://www.mythtv.org/wiki/Translation#Do_the_translation">https://www.mythtv.org/wiki/Translation#Do_the_translation</a>, is what causes the problems.</div><div>I did expect the "mythfrontend -p" to ask for the language; instead it comes up with a backend selection page.</div><div>There are two backends shown with completely identical descriptions.</div><div>Selecting the first one gives a popup box with a prompt for a PIN code. Entering 0000 fails, the box remains.</div><div>Selecting the second one works OK without a PIN code. This happens to be the production backend in my attic and this is not what I wanted so I just exited after clicking around for a while.</div><div>Now on BOTH systems, my laptop and the one in the attic, the "This server is the Master Backend" is unchecked.</div><div>I have been able to reproduce this once but not twice.<br></div><div><br></div><div>Looks like there are the following issues:</div><div><br></div><div>- The "mythfrontend -p" command is expected to ask for country and language but instead it does something completely different. It could be that the documentation in <a href="https://www.mythtv.org/wiki/Translation#Do_the_translation">https://www.mythtv.org/wiki/Translation#Do_the_translation</a> is not correct.</div><div>- The backend configuration is clobbered by "mythfrontend -p". This should never happen and is the most serious issue.</div><div><div>- I can NOT start mythfrontend when I select the backend via the backend selection page; it then asks for a PIN code which is not accepted.  I can however just start mythfrontend without the "-p" option and then it starts OK. This is inconsistent.</div><div></div></div><div>- The two backends presented in the backend selection page have a 100% identical description. This makes selecting the correct backend a lottery.</div><div><br></div><div>I also think that the default for mythtv-setup should be to appear in a window and not full screen. Typical use for mythtv-setup, at least for me, to run it via ssh on a computer screen and not on the TV. The annoying thing is that this can only be changed in mythfrontend.</div><div><br></div><div>Klaas.</div><div><br></div><div><br></div><div><br></div><div><br></div><div><br></div><div><br></div><div><br></div><div><br></div><div> </div></div></div></div>