[mythtv] Qt minimum required versions increased

Gary Buhrmaster gary.buhrmaster at gmail.com
Fri Feb 16 03:30:53 UTC 2024


On Thu, Feb 15, 2024 at 10:28 PM David Hampton via mythtv-dev
<mythtv-dev at mythtv.org> wrote:
>
> Hi all,
>
> I've just made a series of commits that increase the minimum required
> versions for both Qt5 and Qt6.
>
> The minimum required version of qt5 is now 5.15.2.  This removes a lot
> of conditional code for supporting older version of qt.  With the
> exception of Ubuntu 20.04, any system that could compile v34 can still
> compile master.  Ubuntu 20.04 isn't one of the officially supported
> releases for v34 (they're Ubuntu 22.04/24.04), and also 20.04 will
> become end of life shortly after master is released as v35.
>

Per the development guidelines, the only targets
are Debian "stable", Fedora "current" and "current-1",
and Ubuntu "current" and "LTS" (which does not
technically include 22.04, let alone 20.04, if one
uses the term "LTS" as meaning the latest)

At this point, removing the buildbot worker for 20.04
makes sense to me (as the person "shepherding"
the 20.04 worker, shutting it down would not be
considered a large burden (`shutdown -h now`,
and along with "virsh autostart .... --disable")).
Let me know if you agree, or wish to continue it
for fixes/34 and fixes/33 only (clearly master
no longer applies, and the worker for master
should be removed).


More information about the mythtv-dev mailing list