[mythtv] Qt minimum required versions increased

David Hampton mythtv at love2code.net
Thu Feb 15 22:28:03 UTC 2024


Hi all,

I've just made a series of commits that increase the minimum required
versions for both Qt5 and Qt6.

The minimum required version of qt5 is now 5.15.2.  This removes a lot
of conditional code for supporting older version of qt.  With the
exception of Ubuntu 20.04, any system that could compile v34 can still
compile master.  Ubuntu 20.04 isn't one of the officially supported
releases for v34 (they're Ubuntu 22.04/24.04), and also 20.04 will
become end of life shortly after master is released as v35.

The minimum required version of qt6 is now 6.4.  All of the changes
here convert a qt function to either 1) another pre-existing Qt
function, or 2) a c++17 standard library function.  Any system that
could compile for Qt6 before should still be able to compile for Qt6.

David



More information about the mythtv-dev mailing list