[mythtv] [mythtv-users] Android mythfrontend mysql driver problems

David Engel david at istwok.net
Wed Nov 9 16:10:29 UTC 2022


On Wed, Nov 09, 2022 at 06:23:54PM +1100, Mark Spieth wrote:
> On 3/11/2022 9:57 am, David Engel wrote:
> > On Thu, Sep 29, 2022 at 03:01:25PM +1000, Mark Spieth wrote:
> > > I updated mariadb connector to 3.2.6 but I havent seen any issues with
> > > recent builds. Last one I did was end of May using the previous build env
> > > settings if SDK 28, NDK 21.4... and tools 29.0.3. I remember a 32 bit build
> > > issue I was fixing at the time.
> > Mark,
> > 
> > I tracked down a problem I saw to mariadb connector 3.2.6.  Using the
> > default, nvshield config, my resulting apk fails silently when
> > deleting recordings.  By that, I mean the recording gets removed from
> > the list in playbackbox but as soon as there's a refresh or
> > playbackbox is re-entered, the recording is back.
> > 
> > ENOTIME kept prventing from working on the problem a lot but I finally
> > tracked it down to the query in ProgramInfo::ProgramInfo(uint
> > _recordedid).  Specifically, the starttime that gets read from the
> > database is empty/blank.  That leads to it being set to the current
> > time in PI::clear().  Ultimately, the backend is not able to look up
> > the correct recording when it gets the delete request.
> > 
> > The problem is fixed for me by switching back to mariadb connector
> > 2.3.7.
> > 
> I have the qt date fix in my myth master tree and I havent seen the problem
> since I added that. Before that, when I deleted a program, went back to main
> menu and then back into playbox the program was still there.
> 
> Probably the same problem (timezone info in rendered datetime string)

Good you could reproduce and fix it.  When do you think you'll commit
it?

BTW, do you have problems resuming mythtv from sleep on the shield?
With the shield updates over the last several months, I have
increasing issues.  One looks similar to the old one where events
weren't ignored/processed correctly.  This results in a black screen
for a very long time.  Another is where mythtv appears to have lost
all database connections.  This results in mythtv not showing any
any recordings in playback box until it is restarted.

David
-- 
David Engel
david at istwok.net


More information about the mythtv-dev mailing list