[mythtv] Question about new build requirements for NVDEC

David Engel david at istwok.net
Wed Jan 16 23:35:23 UTC 2019


On Wed, Jan 16, 2019 at 08:15:56PM +0000, Gary Buhrmaster wrote:
> On Wed, Jan 16, 2019 at 7:41 PM Peter Bennett <pb.mythtv at gmail.com> wrote:
> > For future builders including end users and package builders, requiring
> > a package from deb-multimedia may be a problem?
> 
> The number of people building from source is likely
> smallish compared to what gets installed via someone
> else's packaging.  deb-multimedia, as I understand it,
> has an interesting history, and can require careful
> configuration to avoid certain issues and anomalies.
> 
> Installing anything locally into /usr/local has its own
> issues and anomalies of course.
> 
> > I imagine Ubuntu would not accept a package that
> > required a package from deb-multimedia as a
> > dependency for building.
> 
> Probably not, but it is also possible no one has
> started the process(es) to get nv-codec-headers
> into Ubuntu along with ffmpeg.  I have no standing,
> but someone who did could look into starting the
> process to get those headers packaged for the
> good of everyone.
> 
> And one could consider creating a PPA now, until
> Ubuntu steps up.
> 
> > On the other hand, we carry our own copy of FFmpeg in the MythTV
> > repository, so it may make sense that we should carry a copy of this as
> > well, since it is really a part of FFmpeg.
> 
> Certainly a possibility, but anything you do not need
> to carry is likely better.  And if the distro provides the
> headers, you should probably prefer them (as
> configure now does for a number of libraries)

As a long-time, Debian user, and one who has been bitten by problems
caused by installing d.m.o packages, I strongly recommend against
using them.  We should either include the headers in our own source or
create packages for them until they are included in the distros.

David
-- 
David Engel
david at istwok.net


More information about the mythtv-dev mailing list